Support » Plugin: WP Performance Pack » class.wppp_mo_dynamic.php:515 – substr() expects parameter 2 to be int, string g

  • Resolved erwinbr

    (@erwinbr)


    Hello, I just installed your module to see if it does what I need and I noticed this notice in the log/debug bar:
    NOTICE : wp-content\plugins\wp-performance-pack\modules\l10n_improvements\class.wppp_mo_dynamic.php:515 – substr() expects parameter 2 to be int, string given
    require_once(‘wp-admin/admin.php’), require_once(‘wp-admin/admin-header.php’), do_action(‘in_admin_header’), WP_Hook->do_action, WP_Hook->apply_filters, wp_admin_bar_render, do_action_ref_array(‘admin_bar_menu’), WP_Hook->do_action, WP_Hook->apply_filters, wp_admin_bar_updates_menu, wp_get_update_data, _n, apply_filters(‘ngettext’), WP_Hook->apply_filters, WPML\ST\MO\Plural->handle_plural, __, translate, WPPP_MO_dynamic_Debug->translate, WPPP_MO_dynamic->translate, substr

    I guess that solving it is as simple as replacing self::PLURAL_SEP with 0 on the given line.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Bjoern

    (@greencp)

    You are absolutely right. Don’t known how the PLURAL_SEP slipped in as it doesn’t make any sense to use it there. Luckily it doesn’t break anything, except for the notice. I’ll fix this with the next update.

    Thread Starter erwinbr

    (@erwinbr)

    Thanks!

    Plugin Author Bjoern

    (@greencp)

    2.2.5 is now available and should fix this.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘class.wppp_mo_dynamic.php:515 – substr() expects parameter 2 to be int, string g’ is closed to new replies.