Support » Plugin: Kirki Customizer Framework » Class ‘WP_Customize_Code_Editor_Control’ not found

  • Resolved shanthiraj691

    (@shanthiraj691)


    I got “Fatal error: Class ‘WP_Customize_Code_Editor_Control’ not found in /home/chennaivasthu/public_html/testvasthu/wp-content/plugins/kirki/controls/php/class-kirki-control-code.php on line 23” error message when tried to customize theme. I am using https://wordpress.org/themes/airi/. And my website WordPress Version is 4.7.3.
    So I can’t use your plugin.

Viewing 1 replies (of 1 total)
  • Plugin Author Ari Stathopoulos

    (@aristath)

    Hello there @shanthiraj691,
    The WP_Customize_Code_Editor_Control was introduced in WP 4.9 which was released almost 2 years ago.
    Kirki itself clearly states in it’s plugin page that it requires WP 4.9 and above.
    If you update your WordPress installation everything will work.
    Please note that updating your installation is highly recommended not only for Kirki but in general as a security precaution. There have been a lot of security updates since the version you’re using – which was released in 2016.

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.