Support » Requests and Feedback » class-snoopy.php – out of date

  • I was poking around some of the php files and found that the class-snoopy.php file is a few versions out of date.

    As of WP 2.0.2, the snoopy class carries a version of 1.01, and the current maintained version is now 1.21.

    Upgrading to the latest version of the snoopy class would fix many bugs, and even a few known security issues.

    As an avid user of WordPress, I recommend that the new version be included into the next release. Having out of date software is a security concern for everyone, whether coded yourself or using someone else’s piece of code.

    Just my .02. 🙂

Viewing 3 replies - 1 through 3 (of 3 total)
  • Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Same goes for the MagpieRSS functions. It would actually be really nice if the script used the MagpieRSS files in an unaltered form, making for easier updates to this functionality. Same goes for Snoopy, really.

    I hacked the newer functionality into the existing file for my Google Calendar widget, but it’s not really the right way to go there. I had to have the latest MagpieRSS though, since GCalendar outputs ATOM 1.0 feeds and the existing MagpieRSS in WordPress only had support for 0.3 feeds.

    Is there some developer forum or some such thing where I can contribute code and ideas and such? I’d be willing to make changes and contribute them, but I don’t see anywhere to do so.

    there is. visit http://trac.wordpress.org

    you can contribute code and make changes if you’d like.
    login with the same username/pass as in these forums.

    You might also drop by the WP Hackers list to kick your ideas around.

    http://codex.wordpress.org/Mailing_Lists#Hackers

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘class-snoopy.php – out of date’ is closed to new replies.