• Resolved imran5211

    (@imran5211)


    I updated the plugin to the latest version today using my GIT workflow and it broke my site.

    PHP Fatal error: Uncaught Error: Class 'Smush\Core\Backups\Backups_Backward_Compatibility' not found in /path/to/public_html/wp-content/plugins/wp-smushit/core/class-modules.php:154

    It looks like the file /var/www/annacenter/public_html/wp-content/plugins/wp-smushit/core/class-modules.php on line 13 is declaring the use of namespaced class ‘Backups_Backward_Compatibility’ however the class is not defined anywhere in the plugin. I think same is the case with line 14 usage declaration (Backups_Controller).

    • This topic was modified 11 months, 2 weeks ago by imran5211.
Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Hassan Akhtar

    (@khaxan)

    Hi there, thanks for using the plugin. The class you are referring to should definitely be there. You can see it here for example: https://plugins.trac.wordpress.org/browser/wp-smushit/trunk/core/backups

    The only thing I can think of is that something went wrong during your upgrade. Could you please install it again to get all the files?

    Plugin Support Nithin – WPMU DEV Support

    (@wpmudevsupport11)

    Hi @imran5211,

    Since we haven’t heard from you for a while. I’ll mark this thread as resolved for now. Please feel free to re-open the thread if you need further assistance.

    Regards
    Nithin

    Thread Starter imran5211

    (@imran5211)

    Hi all
    My apologies for delayed response. It turned out there was /backups entry in .gitignore file of our project which was causing the issue as this plugin also has a folder with the same name.

    The issue can be marked as resolved. Thank you for your response.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Class Smush\Core\Backups\Backups_Backward_Compatibility not found’ is closed to new replies.