Support » Fixing WordPress » Class __PHP_Incomplete_Class has no unserializer

  • Resolved rosariotbsmo


    URL of error:
    Occurrence: twice
    Error message:

    Warning: Class __PHP_Incomplete_Class has no unserializer in /home/content/p3pnexwpnas10_data01/33/2567433/html/wp-content/object-cache.php on line 520

    Warning: session_start(): Cannot send session cache limiter – headers already sent (output started at /home/content/p3pnexwpnas10_data01/33/2567433/html/wp-content/object-cache.php:520) in /home/content/p3pnexwpnas10_data01/33/2567433/html/wp-content/themes/invicta/includes/logic-hooks.php on line 210

    Warning: Cannot modify header information – headers already sent by (output started at /home/content/p3pnexwpnas10_data01/33/2567433/html/wp-content/object-cache.php:520) in /home/content/p3pnexwpnas10_data01/33/2567433/html/wp-includes/pluggable.php on line 1171

    The first error also showed up on another site on my server with go-daddy but just in the header area of the site and the rest of the page loaded normally. These errors are random in occurrence thus far, but not sure what the cause, but started after update to 4.5 but I did update over a week ago, but because of how random they are maybe the error has always been their since updating. Daddy said its a WordPress file so its a WordPress issue, so now I am reaching out to hopefully figure out why these warning show up and how to resolve them.

    If you need anymore info let me know, and thanks in advance!

Viewing 15 replies - 1 through 15 (of 55 total)
  • Given the current randomness of your issue, it’s hard for me to come up with some advise. Usually, when one sees an issue, the first step is to reproduce it using a different browser. One that has had its cache completely wiped. Then tested again using the original browser that has also had its cache wiped.

    Once the issue is reproducible over a few different browsers — and if possible computers — then it’s a good idea to rule out any 3rd party incompatibility issues. To do this all one needs to do is temporarily disable ALL of their plugins AND switch back to the default Twenty Sixteen (or one of the Twenty series) theme.

    But, given your issue’s randomness, I just tried to reproduce the issue using a variety of browsers. All of which had had their cache wiped and could NOT reproduce the issue:

    Steps taken:
    1. Go to

    Looked over site for any kind of Warning message(s). Nothing found.

    Browsers tested:
    – Mac Firefox 45.0.2 (debug = false)
    – Mac Firefox 45.0.2 (debug = true)
    – Mac Chrome 50.0.2661.86 (64-bit) (debug = false)
    – Win Edge 25.10586.0.0 (debug = false)
    – Win IE 11.212.10586.0 (debug = false)

    What were the exact steps you took to reproduce the issue? Is it possible one needs to fill out the form and submit it or something like that in order to reproduce the bug???

    I know its random, listen to all I know, Earlier this morning on the same URL one of our employees had gone to that form and it gave a PHP error, she didn’t not take a note of it other then telling us what happened. I tried it myself and got no errors at all so thought it was a one time thing. Then two hours later on another site that we host on our server through our manage wordpress with Godaddy, but it was on the homepage of and the page did load completely and only showed this error on top
    Class __PHP_Incomplete_Class has no unserializer in /home/content/p3pnexwpnas10_data01/33/2934******
    The issue with this error on maranoeyecare was that the client sent in a screenshot (i did not see myself) but the screen shot didn’t have the full root so I am not sure if it was the same warning root but the beginning matched the error code i got 30 min later. Because i knew it was a php warning and i know they sometimes come by mistake, but i needed to see the full warning message. So I went to and started going thru the menus page by page but nothing, then i went back to the page (directly entering it in the address bar and that when all 3 warnings spawned, which shocked me because i was expecting only 1 warning like the screen shot, but instead of the page loading with just the warning message ontop, instead the whole page failed to load and outputted these three error message above. So yes it is vague, and random, I can try turning on and off plugins but idk how to reproduce the warnings in the first place, I just know they happen and not sure why, and thought maybe someone has ran into this problem, I will keep updating here if i find more out but to give you more details now is impossible until it happens again and where and why, all report issue have been with Chrome latest version. But will Verify to make sure.
    I do thank you guys for your time and energy!

    P.S. I did reach out to Godaddy but they said it was a wordpress issue and to seek support here for this, they also could not reproduce the warning, which always seems to be the case when you want to prove your point lol!

    I have the same issue. WordPress 4.5 on GoDaddy.

    I’ve seen the issue intermittently on a few pages, clearing the godaddy cache has almost always fixed the issue.

    However, I am now getting the error consistently on my yoast seo generated sitemap pages.

    For example, this page (at the time of writing) consistently has the error message.

    Clearing the cache doesn’t seem to be fixing it.
    Any help appreciated.

    Yes the Cache flushing has seemed to help, but I see that your saying about your sitemap I got your error as well when clicking your link my sitemap doesn’t run into that problem, however I feel like the flush cache might only work on files that are connected to the Database, sitemaps should only be in the FTP, now I am not sure at all about this but thats what I think, but might be something totally different. All I know is these errors are random, hard to reproduce, and am not sure if its just some small glitch that fires off randomly. I sure hope we find a solution but if you seem to be having more error codes show up more and more keep posting them here and letting us know how or what you did to get them to show up, browser, etc, the more details we can get maybe we can get to the bottom of this.

    I just got off the phone with godaddy support. They said because I’m using godaddy managed wordpress, they could change some settings at their end.
    They did this, and the error message has now gone away.
    I’ll keep an eye on it over the coming days to see if it reappears, but it may be worth another call to godaddy support to see if they can help.

    Son of a bi** I use manage wordpress and told them that when on chat lazy! Okay well Please keep me update @mlamb76 if you see anymore errors and if so I will reach out to go daddy via phone on Monday to see if they can “mess with the settings in the backend” Thanks for the update!!

    This seems to be a Managed WordPress / 4.5 / GoDaddy caching issue

    If you have this issue a simple call to support and ask them to do a full flush of the system cache (a tool they have on their side) different than the cache in the dashboard this should resolve the issue

    I agree 100% with what @sflwa just said. Try that and let us know if you’ve resolved your issue! 🙂

    I’m having the same problem – it’s a GoDaddy issue.

    Ditto this issue on GoDaddy managed wordpress.

    I’ve just called GoDaddy and they ran a deeper cache flush on my site – hopefully that will sort it out?

    I did the same. Fingers crossed.

    ‘Warning: Class __PHP_Incomplete_Class has no unserializer in /home/content/p3pnexwpnas07_data02/37/2743037/html/wp-content/object-cache.php on line 520’ is the error I get too! I’m on GoDaddy managed WordPress hosting and will call them about this to see what a deep cache flush on the back end will do. The error seems to go away when I deactivate my plugin Better WordPress Minify but that my be a coincidence since that plugin affects/interacts with the cache of the site (as far as I understand). Anyone else running this plugin?

    Hey everyone! Yes so if you are with A Godaddy Manage WordPress, (did not confirm if it just WordPress) but asking them to flush their cache will solve this error(I’ve been warning free for almost a week) so safe to think it worked, it is a cache problem but not sure if other plugins can affected it, but if you can clear its cache I would think it would clear that error(as well as call your host to flush their cache) Thanks for all the help everyone and hope this helps others with the same issue!

    This is continuing on and our site is broken again despite flushing the system cache with GoDaddy support. The issue re-occurs within a minute or so, and the Yoast sitemaps are also broken with Google now flagging these errors to us via Webmaster tools.

    I called GoDaddy to escalate this issue. It’s been over a week and it’s not acceptable that WordPress sites break to external users with error messages without the bug being fixed for so many days.

Viewing 15 replies - 1 through 15 (of 55 total)
  • The topic ‘Class __PHP_Incomplete_Class has no unserializer’ is closed to new replies.