Support » Plugin: BuddyPress Like » Clashes With WP 4.0

Viewing 4 replies - 1 through 4 (of 4 total)
  • I’m having the same issue. Anyone know a fix please?

    Any ideas anyone? šŸ™‚

    roy191991

    (@roy191991)

    Try this change your asset/js/bp-like-min.js

    function bp_like(){jQuery(“.like, .unlike, .like_blogpost, .unlike_blogpost”).click(function(){var e=jQuery(this).attr(“class”),t=jQuery(this).attr(“id”);jQuery(this).addClass(“loading”);jQuery.post(ajaxurl,{action:”activity_like”,cookie:encodeURIComponent(document.cookie),type:e,id:t},function(n){jQuery(“#”+t).fadeOut(50,function(){jQuery(this).html(n).removeClass(“loading”).fadeIn(50)});var r,i;if(e===”button like”){r=t.replace(“like”,”unlike”);jQuery(“#”+t).removeClass(“like”).addClass(“unlike”).attr(“title”,bp_like_terms_unlike_message).attr(“id”,r)}else if(e===”acomment-reply bp-primary-action like”){r=t.replace(“like”,”unlike”);jQuery(“#”+t).removeClass(“like”).addClass(“unlike”).attr(“title”,bp_like_terms_unlike_message).attr(“id”,r)}else if(e===”button like_blogpost”){r=t.replace(“like”,”unlike”);jQuery(“#”+t).removeClass(“like_blogpost”).addClass(“unlike_blogpost”).attr(“title”,bp_like_terms_unlike_message).attr(“id”,r)}else if(e===”button unlike_blogpost”){r=t.replace(“unlike”,”like”);jQuery(“#”+t).removeClass(“unlike_blogpost”).addClass(“like_blogpost”).attr(“title”,bp_like_terms_unlike_message).attr(“id”,r)}else if(e===”acomment-reply bp-primary-action unlike”){r=t.replace(“unlike”,”like”);jQuery(“#”+t).removeClass(“unlike”).addClass(“like”).attr(“title”,bp_like_terms_like_message).attr(“id”,r)}else{r=t.replace(“unlike”,”like”);jQuery(“#”+t).removeClass(“unlike”).addClass(“like”).attr(“title”,bp_like_terms_like_message).attr(“id”,r)}});return false})}jQuery(document).ready(bp_like);jQuery(document).ajaxComplete(bp_like);

    $( “#dialog” ).dialog({ autoOpen: false });
    $( “#opener” ).click(function() {
    $( “#dialog” ).dialog( “open” );
    });

    Plugin Author darrenmeehan

    (@darrenmeehan)

    If you could update to the latest version, currently 0.1.8 this issue should be working.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Clashes With WP 4.0’ is closed to new replies.