Support » Plugin: WP Webhooks » Clarification on “Send Data” Formatting

  • Resolved streampro

    (@streampro)


    Hey there. Trying to use your plugin, I’ve got a server running and have entered the webhook URL into the “Send Data On Register” webhook trigger. When I hit the “Send demo” link, nothing appears to happen at the server.

    I’ve looked in the docs (both in the plugin and your site), but it doesn’t seem to mention what format it sends this data down in, only that it sends down a user object with meta data. Is this “application/json” content-type? Is it “application/x-www-form-urlencoded”? Something else? Do you have an example server that will handle a webhook trigger?

    I also cannot tell if it’s an actual error, and maybe nothing is getting triggered when I hit the “Send demo” link. I’ve tried to accept every kind of content-type and data types I could think of, but nothing seems to work.

    Thanks. I really would love to use your plugin, it seems extremely useful!

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Ironikus

    (@ironikus)

    Hey @streampro, thanks for your message!
    We send it using the JSON content type.
    Can you try if you get a response using the following website? https://webhook.site
    There you can just copy the URL, paste it into the “Send Data On Register” trigger and send it.
    If this works, it might be something on your system/server.
    What may be an issue is that we currently use the WordPress safe remote Post Request and there is sometimes an issue with the validation.
    You can find a solution for that here that you can try as well: https://github.com/ironikusagency/wp-webhooks/issues/1
    Hope this helps!

    streampro

    (@streampro)

    Thanks, that definitely helped! I believe it had something to do with testing on a non-standard port. I was using port 5000 for testing, so my webhook URL had that included. It did not seem to want to send any calls over http on a non-standard port. Not sure if this was an issue with our server or something the plugin might be doing.

    I tested it using webhook.site (great resource, btw, thanks for sharing that), and it worked fine. After re-creating the exact message received at webhook.site in Postman and hitting my local server, it was reading the message fine, but I still wasn’t getting any hits from the server. When I removed the port and used 80, everything was fine.

    Thanks for your help and for the plugin, of course! Cheers!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Clarification on “Send Data” Formatting’ is closed to new replies.