Support » Plugins and Hacks » CKEditor 4.0 stays blank

CKEditor 4.0 stays blank

  • I’ve read the many threads about CKEditor 4.0 being blank, but I can’t find the reason why I am still stuck.
    When I enable CKEditor 4.0, editor is blank, only shows one button. Can’t switch to the HTML tab either. I can sometimes see HTML in the visual editor when I drag to select stuff, but that’s it. Works fine with the standard crappy editor.
    CTRL+SHIFT-J shows several java errors in load-scripts.php line 79, “Cannot call method add or undefined”, pertaining apparently to jQuery.
    Did the Moono/update options thingy, no change.

    Help much appreciated.


Viewing 15 replies - 1 through 15 (of 19 total)
  • Same for me. I had to deactivate it. wp 3.5 and ckeditor 4

    I believe there was some google xml sitemap plugin causing trouble. Shut your plugins off and turn them back on one at a time to see what did it. I was surprised that this messed mine up, since it didn’t seem to have anything to do with editing, but it did.

    Sorry, can’t be an xml sitemap plugin. I’m working on a new installation, only Akismet was activated. Turning it off did not help.

    By the way, yesterday I had the same problems on other sites, too.

    Plugin Author michal


    please write what theme/template do you use . Please also write what errors do you see in Firebug console (Firefox add-on) .

    I have tried this plugin in my local computer using Twenty Twelve.
    In many times I want to edit the old post, the editor is blank…when I save the old content is lost.
    I have tried and only three plugin activated: CKEditor, SyntaxHighighliter and SyntaxHighighliter for CKEditor.
    I am not brave to try it in my live blog before everything is fixed.
    I’m sorry and thanks.

    I’m using TwentyTwelfe, too. I will try a different theme later and report back!

    Sorry, don’t have Firebug and wouldn’t know how to use it.

    Plugin Author michal


    please paste links to ‘SyntaxHighighliter’ & ‘SyntaxHighighliter for CKEditor’ plugins and write which versions do you use . It will help us to reproduce this issue.

    I did some testing, and it’s working now. I tested with a new theme, and it worked. I switched back to Twenty Twelve, and it worked, too!

    So it seems that switching the theme off and on solved the problem.

    (It might be more complicated, since I switched around many things, including reuploading theme files, turning the plugin on and off, etc.)

    Still, something seems wrong, because I had the same problem on another site, and switching themes shouldn’t be necessary. I tested only 1 site now, so I don’t know if my solution is in any way consistent and repeatable.

    You’ve got to do one thing at a time when you’re troubleshooting like this.

    I know, I got carried away. 🙂
    Tons of other things to do, no time for scientific testing…

    Anyway, my recommended steps are:
    Reupload theme and plugin files.
    Deactivate and activate theme after activating plugin.

    I understand — It’s damned aggravating when stuff doesn’t work. Did you see my post on KCFinder for CKEditor? Another case of “WHY YOU NO WORK!” but I eventually got it. You might like it actually, since you’re using CKEditor too.

    Integrate KCFinder with CKEditor in WordPress

    I’m trying using these:
    and of course
    under WordPress 3.5 installed on my local computer and the old posts are imported from my live blog.
    The big problem is only when editing the old posts. No problem when creating a new post, it works as desired (many thanks for your hard effort to create this useful plugin).
    About debugging, oh, I have installed firebug but I’m so beginner in this world of web development so I don’t understand how to use it now.
    I have tried to reinstall all freshly twice.

    I’m sorry and many thanks for all your kindness.

    Oh, I try again just now in my local computer and deactivate all other plugins. Only activate CKEditor.

    I open randomly my old posts and also the posts from the theme data test.
    When I open posts with very little content (1 until 2 or maybe 3 paragraphs), CKEditor always works, the content is loaded correctly. But when I open posts with very long content with many paragraph, the CKEditor is blank no content is loaded in many times (not always). Some times the long content with many paragraph is loaded but when switching between visual and html the content is lost…

    I’m sorry and again many thanks for all your kindness.

    It’s not just a lag is it? I’ve noticed that CKEditor is slower about bringing my content up than the default WP editor. This is compounded by my ISP (Fairpoint in Maine) which is generally just a hair faster than molasses going up a hill in January…

    I notice CKEditor hanging when working on sites from home, and better when I’m working on my employer’s site while I’m at work.

    Plugin Author michal


    please write us in what Editor you created old posts ? It was created with default editor in WordPress or you created it in older version of CKEditor for wordpress plugin ? Older post are from wordpress 3.4 ?

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘CKEditor 4.0 stays blank’ is closed to new replies.