Support » Plugin: Cimy User Extra Fields » Cimy user extra fields plugin breaks new user signup notification emails

Viewing 3 replies - 1 through 3 (of 3 total)
  • It might be useful for others to know the way I came up with to pin down what plugin is causing problems without doing the whole ‘switch off all plugins and slowly switch them back on one-by-one’ thing, which is usually completely impractical (especially on a live site)…
    You do have to have access to the command line to do this though.

    0) Figure out EXACTLY what the problem is – harder than it sounds and involves lots of experimentation – in my case people were trying to sign up to a bb-press forum and though getting their activation emails they were not getting username and password emails. It was only when I was reduced to setting up their accounts manually, I realised that in fact a more general problem was that though user email notification was on, my test user emails were not getting their new user email notification – now I know what the underlying issue is and what to search for…

    1) Ascertain the likely function that is having problems – in this case I searched through the WordPress function reference here: https://codex.wordpress.org/Function_Reference for ‘notification’ and found the likely “wp_new_user_notification” function…

    2) search the plugins directory for any occurrence of this text string to find out which plugins might be messing with it… I navigated to the plugins directory (/<web-root>/wp-content/plugins) and typed:
    # find . -type f -exec grep -i ‘wp_new_user_notification’ {} +
    …which listed all the occurrences of that string.
    In this case they were: cimy-user-extra-fields and login-with-ajax
    I tried deactivating each of these in turn and found that the emails started going out again when I deactivated the cimy user extra fields plugin.

    Now I have a choice – I can either leave it deactivated so that new users can sign up or figure out a way to get this plugin working appropriately as it is important to the function of my site!

    Hope this is useful to someone else…
    theWoosh

    temp0admin

    (@temp0admin)

    totally correct theWoosh, same here, 🙁

    anyone have any solution to fix this plugin?

    ps just to add, in my case it was working for while and then stop, is it maybe WP v4.6.1 problem?

    Just to say that I have just had the same problem with a different site on WP 4.7.3 – the confirmation email is not being sent.
    I deactivated cimy user extra fields and users can now sign up. I did then narrow it down further. Since the email that doesn’t get sent is the second one – the confirmation email , I switched off the confirmation email and users are now able to signup.

    So this problem has not gone away… I hope this might help the writer address it.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Cimy user extra fields plugin breaks new user signup notification emails’ is closed to new replies.