Event Organiser
[resolved] Chrome only browser not displaying [eo_venue_map] (9 posts)

  1. nhtvpostma
    Posted 3 years ago #

    For some reason Chrome is the only browser that does not diplay the [eo_venue_map]. I'm running the plugin in a https environment with a SSL certificate, mayby that could have something to do with it?

    Any ideas? Thanks in advance


  2. Stephen Harris
    Posted 3 years ago #

    I mainly use Chrome - I've noticed any problems... Do you get an error in the browser console? Could you link to your site?

  3. nhtvpostma
    Posted 3 years ago #

    Ah yes, the console is giving me this:

    "[blocked] The page at https://insight.nhtv.nl/?event=bress-winterbioscoop ran insecure content from http://maps.googleapis.com/maps/api/js?sensor=false&callback=eo_load_map."

    On this page: https://insight.nhtv.nl/?event=bress-winterbioscoop
    (you can ignore the login screen, this post is not secured)

    I'll probably need to load the maps as https also. How do I do that?

  4. Stephen Harris
    Posted 3 years ago #

    Try editing this line: https://github.com/stephenh1988/Event-Organiser/blob/1.6.3/includes/event-organiser-register.php#L72

    So that it uses https.

    This may not solve it on its own (if not there is another edit you may need to perform).

    I'll be fixing this in 1.7 (currently in beta) (EO should use is_ssl() to determine which protocol to use).

  5. nhtvpostma
    Posted 3 years ago #

    I think I need the other edit also, console is still displaying the same error.

  6. Stephen Harris
    Posted 3 years ago #

    Thought you might. The script that loads maps on the front-end is frontend.min.js, but that is compressed and so not easily edited. I'd suggest deleting it, and making a copy of frontend.js (naming it frontend.min.js) and editing that.

    In that file, make a similar adjustment to this line: https://github.com/stephenh1988/Event-Organiser/blob/1.6.3/js/frontend.js#L46.

    Hopefully that should do the trick - though you may needed to clear your browser's cache.

  7. nhtvpostma
    Posted 3 years ago #

    No luck, did the edit in Frontend.js, cleared browser cache and the server cache (using W3 total cache).. Anything else I can try?

  8. Stephen Harris
    Posted 3 years ago #

    Did you replace the contents of frontend.min.js with frontend.js? (Checking your site its still using https://).

  9. nhtvpostma
    Posted 3 years ago #

    I should read more carefully. Your initial instruction was correct and it solved my problem,

    Thank you!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Event Organiser
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic