Support » Plugin: Advanced Ads – Ad Manager & AdSense » Chrome not working

  • Resolved iverword

    (@iverword)


    After I upgraded the Advanced ads, it doesn’t work in Chrome. It shows that ”
    The site is experiencing technical difficulties.”
    Please help.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Thomas M

    (@webzunft)

    Hi iverword,

    thanks for reaching out.

    I am sorry that you experience issues after the update.

    Can you access your WordPress backend under /wp-admin or do you receive the issue in frontend and backend?

    Thanks,
    Thomas

    Hi Thomas,

    I can access the admin dashboard, and it happens only when using chrome to view the website (https://kikishare.com). When i am trying to deactivate the plugins, it works fine.

    Thanks in advances.

    Plugin Author Thomas M

    (@webzunft)

    Hi iverword,

    thanks for your feedback. I can access https://kikishare.com with Chrome.

    This could indicate that the issue only happens in the frontend if you are logged in. Is this possible? Could you try to log in in another browser and let me know?

    Thanks,
    Thomas

    Hi Thomas,

    I find the error log as below:

    [Thu Aug 15 21:15:49.306917 2019] [proxy_fcgi:error] [pid 13636:tid 140083188213504] [client 42.2.241.35:42836] AH01071: Got error ‘PHP message: PHP Fatal error: Uncaught Error: Using $this when not in object context in /var/www/vhosts/kikishare.com/httpdocs/wp-content/plugins/advanced-ads/classes/frontend_checks.php:835\nStack trace:\n#0 /var/www/vhosts/kikishare.com/httpdocs/wp-content/plugins/advanced-ads/classes/frontend_checks.php(789): Advanced_Ads_Frontend_Checks::can_use_head_placement(‘<script async s…’, Object(Advanced_Ads_Ad))\n#1 /var/www/vhosts/kikishare.com/httpdocs/wp-includes/class-wp-hook.php(286): Advanced_Ads_Frontend_Checks->after_ad_output(‘<script async s…’, Object(Advanced_Ads_Ad))\n#2 /var/www/vhosts/kikishare.com/httpdocs/wp-includes/plugin.php(208): WP_Hook->apply_filters(‘<script async s…’, Array)\n#3 /var/www/vhosts/kikishare.com/httpdocs/wp-content/plugins/advanced-ads/classes/ad.php(582): apply_filters(‘advanced-ads-ad…’, ‘<script async s…’, Object(Advanced_Ads_Ad))\n#4 /var/www/vhosts/kikishare.com/httpdocs/wp-content/plugins/advanced-ads/classes/ad.php(293): Advanced_Ads_Ad->prepare_frontend_output…\n’, referer: https://kikishare.com/wp-admin/plugins.php

    thanks.

    Plugin Author Thomas M

    (@webzunft)

    Thank you for this helpful report. I will try to reproduce and fix it quickly!

    Thomas

    I experienced the same issue just a moment ago when I updated. I have reverted back to previous version which temporarily resolved the issue for now.

    Plugin Author Thomas M

    (@webzunft)

    I can say by now that the issue is only visible to logged-in admins and no other user groups.

    The fix is on its way.

    Thomas

    @seanhelmes , how can you do the fallback?

    • This reply was modified 1 year, 1 month ago by iverword.

    Thomas, so fast!

    I will wait for your good news.

    As always, thank you Thomas!

    Plugin Author Thomas M

    (@webzunft)

    Version 1.14.6 addresses the problem and is online now.

    Props to @iverword for reporting it with the helpful error message.

    Thomas

    works now. perfect!

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Chrome not working’ is closed to new replies.