Support » Plugin: wp-Typography » Chrome adds hyphens

  • Resolved mahrr

    (@maloherry)


    Hello,
    I have an issue with hyphenation on Chrome/Chromium. The browser adds hyphens where there should only be a space. For instance, this sentence appears like this in Chrome :

    Quelle place la révolution sankariste occupe-t-elle, aujourd’hui, au -
    Burkina Faso ?

    on Firefox, it appears the correct way:

    Quelle place la révolution sankariste occupe-t-elle, aujourd’hui, au 
    Burkina Faso ?

    You can reproduce the error on this page and by using development tools to display as a mobile.

    Thanks for your help!

    PS: not sure if it related, but we had the opposite problem with Chromium-based browsers not displaying hyphens that were supposed to be here, and it was corrected after I submitted a bug: https://wordpress.org/support/topic/hyphenation-issue-on-chrome-mobile/

    • This topic was modified 3 years, 2 months ago by mahrr.
    • This topic was modified 3 years, 2 months ago by mahrr.
Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author pepe

    (@pputzer)

    Hi @maloherry, there appears to be a problem in the markup au ­­Burkina, i.e. there is soft hyphen just after the space between au and Burkina. How is that line generated? Can you look in the database to see if this extra soft hyphen is put in by wp-Typography or “native” in your content?

    Thread Starter mahrr

    (@maloherry)

    Hi, in the database, the sentence is clean :
    <strong><span style="color: #038e9a;">Quelle place la révolution ­sankariste occupe-t-elle, aujourd’hui, au ­Burkina Faso ?</span></strong>
    The soft hyphen appears only in Chrome, not in Firefox, which is weird.

    • This reply was modified 3 years, 2 months ago by mahrr.
    Plugin Author pepe

    (@pputzer)

    Interesting. Can you please post your settings from Hyphenation and Space Control tabs? I’ll try to reproduce the issue.

    There are often rendering differences regarding “marginal” features such as soft hyphens (and don’t ask me about spaces in Safari! what a nightmare!).

    Thread Starter mahrr

    (@maloherry)

    For Hyphenation :

    [x] Enable hyphenation (french)
    [ ] Hyphenate headings
    [ ] Allow hyphenation of words...
    [x] Allow hyphenation of the components...
    [ ] Hyphenate words in all caps
    Do not hyphenate words with less than 5 letters
    Keep at least 3 letters before hyphenation
    Keep at least 2 letters after hyphenation
    Browser support: both checked

    Space control:
    Everything unchecked except: Collapse adjacent spacing to a single character, Apply French punctuation rules and Prevent widows.
    Thanks!

    • This reply was modified 3 years, 2 months ago by mahrr.
    Plugin Author pepe

    (@pputzer)

    Just a quick update: I’ve managed to reproduce the issue in the underlying library (PHP-Typography).

    Plugin Author pepe

    (@pputzer)

    @maloherry Sorry for the immediate update, but I’ve looked closer at the line in my code editor and noticed a very small red line in front of some of the words. It turns out the the &shy; is indeed contained in that database snippet (unless you copied that from the frontend instead of the backend editor). I’ve run it through an entity decoder online so that it is easier to see (HTML tags removed):

    Quelle place la r&eacute;volution &shy;sankariste occupe-t-elle, aujourd&rsquo;hui, au &shy;Burkina Faso ?

    Plugin Author pepe

    (@pputzer)

    @maloherry, have you been able to resolve the issue in your DB content?

    Plugin Author pepe

    (@pputzer)

    I assume the issue has been resolved. If not, feel free to reopen the thread, @maloherry.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Chrome adds hyphens’ is closed to new replies.