Support » Plugin: Loco Translate » “Choose a location” radio buttons are missing

  • Resolved asafmoshejul

    (@asafmoshejul)


    When trying to add a new language, under the “Choose a location” section the radio buttons are missing.

    I see the list “Custom”, “System” and “Author” – but no radio buttons next to them, so I can’t continue.

    What can cause it?

    The page I need help with: [log in to see the link]

Viewing 13 replies - 16 through 28 (of 28 total)
  • Plugin Author Tim W

    (@timwhitlock)

    So if it is not a bug it is at least bad error catching of server settings issue.

    If I know what settings could break such simple code execution, I’d check for it. so far this sounds a lot like an opcode glitch, but I can’t possibly account for such things.

    the plugin might benefit from understanding the issue.

    Certainly. So regarding the change you made. Did it fix it permanently? or is only fixed when you echo out? @kikehz does this hack work for you too?

    Perhaps we can find what you both have in common. Can you both provide a full server spec including PHP extensions installed?

    Thanks!

    Regarding your question – if I remove the echo line it reverts (not showing the radio buttons).

    Plugin Author Tim W

    (@timwhitlock)

    Strong indication of opcode cache problem. i.e. Exact same code working differently after modifying the source file.

    OK.

    Reverting to PHP 7.2 (from 7.3) fixed it.

    If you need more information to check the plugin compatibility with 7.3 let me know.

    Thank you for sticking with me.

    Plugin Author Tim W

    (@timwhitlock)

    I will install 7.3 and try.

    However, you said modifying the file fixed it, which doesn’t point to a problem with PHP 7.3 compatibility, does it?

    Do you have the opcache extension installed?

    Yes, it seems like I do:
    https://julstoreusprosites.kinsta.cloud/info.php

    What do you suggest?

    • This reply was modified 2 months, 1 week ago by  asafmoshejul.

    Hi,

    I did nothing bur revert to PHP 7.2.12 (php-fpm) and it works as usual, so surely is a problem with PHP 7.3.0

    If i can be of any help please tell me and thanks for this great plugin

    Plugin Author Tim W

    (@timwhitlock)

    @kikehz I have no issues on 7.3.0. Sorry, I think this is a red herring. Switching PHP version doesn’t prove THAT was the problem. Switching version however, would clear your opcache. Do you have it installed?

    @asafmoshejul I think opcache is a likely culprit, but I am not very knowledgable about it. I would certainly suggest clearing the cache after every WordPress update. A quick Google brings up this potentially useful plugin. https://wordpress.org/plugins/flush-opcache/

    Plugin Author Tim W

    (@timwhitlock)

    @asafmoshejul I notice you have opcache.save_comments disabled. As per the documentation this can break code that uses annotations. Loco Translate uses annotations!

    I will investigate if this is the cause, but I’d actually expect nothing to work at all of annotations were not read.

    So I upgraded again to 7.3 and it is working this time.

    So it might be cache as you suspected.

    Plugin Author Tim W

    (@timwhitlock)

    Thanks for trying. I just upgraded to 7.3.2 and enabled OPcache and I still can’t reproduce what you’ve experienced. I’ll live with it switched on for a while and see if anything breaks.

    I don’t get the save_comments option, because the plugin works fine with this disabled and from what I understand, it shouldn’t. That’s me done for today. Thanks for your help.

    Thank you.

    Great plugin and great support!

    Plugin Author Tim W

    (@timwhitlock)

    I’m marking this as resolved for now, as it seems no code-level bug can be demonstrated.

    To clarify my earlier comment: This plugin CAN be used with save_comments disabled. I completely forgot that I removed the annotation dependence a long time ago.

    If anyone can demonstrate this issue with OPcache disabled then feel free to reopen the ticket with further information.

Viewing 13 replies - 16 through 28 (of 28 total)
  • You must be logged in to reply to this topic.