WordPress.org

Forums

CHMOD issue? (14 posts)

  1. Tek
    Member
    Posted 10 years ago #

    My webhost did something and SCREWED all the permissons and stuff up.

    Now, I can make a post on my blog but if I want to edit it, I cannot!!! It acts like I did, but when you look at the page, it didn't.

    I have no idea where to begin. I've tried setting some things to 777 but nothing is allowing me to fix those posts.

    I also cannot use kitten's spamminator now becasue I end up getting errors.

    Please help.

  2. Mark McKibben
    Member
    Posted 10 years ago #

    Since WP stores all your posts in a mysql database rather than HTML files; setting everything to 777 isn't going to help. It sounds like your rights on your database have been mucked up.

    As for the errors with spamminator: what version of the plugin do you have? And what version of WP?

  3. James Huff
    Volunteer Moderator
    Posted 10 years ago #

    And what kind of errors?

  4. Tek
    Member
    Posted 10 years ago #

    Version 1.2

    The error I can't get to right now becasue firefox has all of my settings and has decided to take a dump on me.

    And...

    I CAN'T LOGIN WITH IE!!! (Of course not! because somehow something is WRONG)

    This all happend after the up to PHP5 OOP! back down to 4 stuff!

  5. Tek
    Member
    Posted 10 years ago #

    Here is the kitten's spam words error:

    Fatal error: Cannot redeclare mk_insert_gui_widget() (previously declared in /home/tekwh0re/public_html/wp/wp-content/plugins/kittensspamwords.php:80) in /home/tekwh0re/public_html/wp/wp-content/plugins/kittensspamwords.php on line 86

  6. James Huff
    Volunteer Moderator
    Posted 10 years ago #

    First, disable Spaminator (if you can't get to the plugin panel, just delete the file). Then, upgrade to WP v1.2.2:
    http://wordpress.org/development/2004/12/one-point-two-two/

  7. Tek
    Member
    Posted 10 years ago #

    Ah.

    Well that is a no go. I cannot update wordpress at this time. That would mess up all the work that is there now.

  8. DianeV
    Member
    Posted 10 years ago #

    If I could make a suggestion: I keep a running record of the files I've modified (including how) so that if I have to redo anything -- or upgrade -- I'm not stuck with having to remember.

  9. James Huff
    Volunteer Moderator
    Posted 10 years ago #

    What work have you done that would be destroyed?

    Here are the upgrade instructions:
    http://codex.wordpress.org/Upgrading_WordPress

    Here are the change logs for v1.2.x:
    http://codex.wordpress.org/Changelog/1.2

  10. chuckblue
    Member
    Posted 10 years ago #

    make sure your browser has cookies turned on.

    Kept me out a couple of times of my blogs.

  11. Mark McKibben
    Member
    Posted 10 years ago #

    @Tek, other people have reported in these forums that WP 1.2 doesn't play well with PHP5, though I've heard that the nightlies for WP 1.5 work somewhat better. NOTE: I'm not running either PHP5 or WP 1.5; so I can't confirm that. Still, since you're not interested in upgrading WP from 1.2 to 1.2.2; I'd recommend you stick with PHP4 (4.3.10 or later would be best for security).

    Since you can't login using IE; you should try deleting all your temporary internet files and cookies (or at least the cookies for your site) and then try logging in again. If that doesn't work; we'll need to know what error(s) you're getting when you try.

  12. Tek
    Member
    Posted 10 years ago #

    I'd love to go to 1.5 and I am testing it out and working on it in another directory.

    I have no control over what version of PHP the host uses.

    I was finally able to get my FireFox working properly again (I swear it just went CRAZY- had to uninstall and reinstall).

    I bitched at my webhost again and now kitten's spam words are working again so maybe they did something with the permissions on the server again.

    Trust me, I really want to go over to 1.5 but since I am going to really be locking down my website at the same time, I need to get viewlevel and coppermine to intergrate seamlessly before I upgrade.

    Thanks for all your suggestions and help! =)

  13. James Huff
    Volunteer Moderator
    Posted 10 years ago #

    Knowing how support of plugins vs. different WP versions goes, you may want to get viewlevel and coppermine to intergrate seamlessly after you upgrade.

  14. twistedemotions
    Member
    Posted 10 years ago #

    Tried out just throwing the old viewlevel and wordpress 1.5 together.

    Sorta works. You have to not be using a calender (as I don't know how to fix that).

    For some reason it hides the post but displays the "Sorry, you need to be logged in to see this post" message regardless of what I set $private_message variable to.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.