Support » Plugin: Wordfence Security - Firewall & Malware Scan » Chmod error installing Wordfence version 7.4.4

  • Resolved deadparrotsoftware

    (@deadparrotsoftware)


    Anyone else having a strange error about ‘chmod not allowed’ when trying to install the wordfence 7.4.4?

    wordfence runs.
    Other plugins update fine.
    Site runs etc.

    But I get error:
    Warning: chmod(): Operation not permitted in [edited]appbuzzinga.com/httpdocs/wp-admin/includes/class-wp-filesystem-direct.php on line 168

    NOTHING has been altered or changed. Very odd. Updated 11 plugins today, but this one fails??

    Sid

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Hi @deadparrotsoftware,

    Can you login to your host, to see what the owner/group is for the wp-content folder?

    Something like WinSCP, where it shows the group/owner in this image example: https://winscp.net/eng/docs/ui_properties#common

    I believe what happened is that the owner changed, and now WordPress is unable to modify the permissions within the wp-content/plugins folder.

    Dave

    Thread Starter deadparrotsoftware

    (@deadparrotsoftware)

    Nice idea, but completely incorrect. Neither the owner nor the permissions have been touched in months. No changes.

    Nothing on the site has been modified in at least a month. Also, I compared the permissions and ownership to several other sites we maintain. 5 in fact. ALL are set the same. 3 update, 2 fail to update.

    We have compared everything we could think of between them, they are all set the same. Even tried exporting the options from a site that updated and imported to those that don’t. Same result.

    It is very odd. But thanks for your suggestion. 🙂

    Sid

    Hi @deadparrotsoftware,

    Thanks for the update.

    Can you please try installing 7.4.5 and let me know if you get the same error?

    Please let me know how it goes.

    Thanks,

    Gerroald

    Thread Starter deadparrotsoftware

    (@deadparrotsoftware)

    No error. Without us changing ANYTHING 7.4.5 worked.

    BUT NOW, our wp-cron gives a wordfence error every time it runs:

    PHP Warning: array_key_exists() expects parameter 2 to be array, null given in
    /var/www/vhosts/appbuzzinga.com/httpdocs/wp-content/plugins/wordfence/vendor/wordfence/wf-waf/src/lib/waf.php
    on line 1989

    You guys you to have such reliable, dependable code. Now updates fail for no detectable reason, and Wordfence is crashing wp-cron!
    What happened?

    Sid

    Hi @deadparrotsoftware,

    Thanks for the kind words, we take a lot of pride in what we do. Unfortunately, sometimes bugs happen.

    With that said, this is a Warning and I’m not sure it’s a bug. Can you please switch the Firewall into Learning Mode and let me know if it helps?

    https://www.wordfence.com/help/firewall/learning-mode/

    Thanks,

    Gerroald

    Thread Starter deadparrotsoftware

    (@deadparrotsoftware)

    We did that. Still the same error.

    Sid

    Thread Starter deadparrotsoftware

    (@deadparrotsoftware)

    How do I edit my posts here?

    Sid

    Hi @deadparrotsoftware,

    After you post, if you hover over the post you should see an “edit” link in the lower right corner. But, I believe you only have a couple of minutes to edit it. After that, it’s permanent.

    I just wanted to let you know that we have a report filed for this Warning, and the developers are aware. For reference, the case number is – FB9295.

    I’ll be sure to update you when I know more.

    Thanks,

    Gerroald

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Chmod error installing Wordfence version 7.4.4’ is closed to new replies.