Support » Plugin: Filter Everything — WooCoomerce Product & WordPress Filter » Chips on mobile not getting shown

  • Resolved holle75

    (@holle75)


    Hi there, beautiful, beautiful plugin. The quickest filter to setup i ever experienced. Thank you very much for that.

    I have one tiny question: On mobile, chips (selected filters) are not getting shown.

    I checked the code and found that class “wpc-custom-selected-terms” is display:none on mobile (<768px)

    is there a setting to also show chips on mobile? I can do it manually but i´m interested.
    Or please explain the logic to me why chips shouldn´t be shown on mobile.

    If not, customer doesn´t know that there is a filter working in the background. A nice way could be to not show all the chips but an information that the results are filtered. (customer could go back to the filter off canvas sidebar and reset filter).

    Ah, ok … i´m using the filter in an off canvas sidebar. customer has to push a button to show the filters. Maybe the behavior is different when you have the filter shown on the main canvas.

    please check

    link “to the page you need help with”

    as an example.

    best regards

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author stepasyuk

    (@stepasyuk)

    Hi @holle75

    Thank you for your warm words about the plugin.

    Yes, you can make Chips visible on mobile devices. Just add them as shortcode – https://filtereverything.pro/resources/shortcodes/#chips and use the parameter mobile For example – [fe_chips mobile="yes"]

    Thread Starter holle75

    (@holle75)

    Thank you for your swift reply!

    Thread Starter holle75

    (@holle75)

    I added [fe_chips id=”10574″ mobile=”yes” reset=”no”] to the shop page where the filter is sitting in the off canvas sidebar.

    Now i can see the chips in mobile view but two times in desktop view.
    This makes sense, cause without adding the shortcode on the shop page i got the chips in desktop view.

    i haven´t found a shortcode for the filter in the off canvas sidebar to prevent showing the chips on the shop page by itself.

    I don´t get the logic behind this.

    Thread Starter holle75

    (@holle75)

    I “tricked” it to work with css (display: block;)
    I´m wondering if there is a “more subtle” way to get the same result?

    Plugin Author stepasyuk

    (@stepasyuk)

    @holle75

    If you need to disable extra Chips widget, you can do it in Filters -> Settings -> Selected Filters (Chips) integration. Here is example – https://prnt.sc/mZh3oOMddvRy

    Thread Starter holle75

    (@holle75)

    thank you. Nice!

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.