• Resolved imtanuki3

    (@imtanuki3)


    Hi,

    So far, just about everything is working quite well, except for Chinese dates.

    EXAMPLE
    Source Date: January 15, 2019
    Chinese Version (should be): 2019 年 1 月 15 日
    Actual Output: 一月 15, 2019

    CHINESE DATE FORMAT
    – order always is YYYY MM DD
    – the Chinese characters for year, month and day follow the actual values.

    TRANSLATE PRESS
    I see the actual dates from pages and posts displayed under String List in TranslatePress, and I’ve manually entered a number of dates as if each date is just another string, but I suspect what’s happening is that TP is doing some kind of auto-translate, which probably works for Western languages, but not for Chinese.

    Is there any way to get around this? It may not seem like a big deal, but my experience with Chinese people is that any other date format really throws them off…

    Thanks!

    • This topic was modified 2 months, 1 week ago by imtanuki3.
    • This topic was modified 2 months, 1 week ago by imtanuki3.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support Dragos

    (@dragosvrejiu)

    Hello,

    You should be able to translate the dates like any other string.

    You might have a bug or conflict with your current theme / plugins.

    Can you please visit TranslatePress -> Settings -> Advanced

    Then, enable these features 1 by 1 in this order and try to see if it makes a difference. Also please disable or clear the cache if you have any.

    1. Fix missing dynamic content
    2. Disable dynamic translation
    3. Fix spaces between HTML attributes
    4. Fix broken HTML

    Let me know how this goes.

    Best regards,

    imtanuki3

    (@imtanuki3)

    Dragos,

    Thx for the quick reply.

    RECOMMENDED SETTINGS (from your note above)
    Sorry, I should have noted that I had already:
    – Set Fix Missing Dynamic Content = TRUE

    This was to address a separate issue with Layer Slider.

    I tried items 2-4 and that didn’t help.

    POSSSIBLE BUG
    Clearly, TranslatePress is attempting to auto format dates for Chinese, since post dates are reformatted from “September 18, 2019” –> “九 月 18, 2019″, where:
    九 = the value 9 (for September)
    月 = the word for month

    So, it looks like someone took a shot at formatting dates according to Chinese standards, but may not have known the correct format.

    The fact that dates are getting reformatted (just not correctly) tells me this is probably not a theme or plugin conflict.

    EXCLUDE GETTEXT STRINGS
    I’m wondering, how does TranslatePress obtain metadata (i.e. dates) from posts? Is it thru a GETTEXT string? If so, could you tell me what that string is and would adding that value to the Exclude Gettext Strings list disable auto-translate for dates?

    If I could simply disable the auto-formatting of dates, I could live with manually translating each date as a string – in fact, TranslatePress’ translation admin screen serves up each of my post dates as strings, which I have translated. But when the relevant page is rendered, it appears that TranslatePress bypasses the string translations and attempts to auto-format dates.

    It’s worth noting that Chinese is one of the few languages that not only changes the date component sequence (from MM-DD-YYY or DD-MM-YYY to YYYY-MM-DD), but it also mandates:
    – year must be expressed as a 4 digit value.
    – the actual words for year, month and day have to be appended as suffix’s to the component values.

    So, I’m thinking the fastest and easiest resolution would be disabling auto-format and forcing users to manually translate each string…

    Thanks again!

    • This reply was modified 2 months ago by imtanuki3.
    • This reply was modified 2 months ago by imtanuki3.
    Plugin Support Dragos

    (@dragosvrejiu)

    Hello,

    Thank you for your patience.

    I have successfully replicated your issue.
    TranslatePress does not format dates, it is WordPress that does that.

    Please check the attached screenshot:https://prnt.sc/q2spak
    You can find the shown settings in Settings->General .

    With the best regards,

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.