Ninja Forms
Chinese characters not working (4 posts)

  1. chiappa
    Posted 3 years ago #

    When I try to enter chinese characters to the ninja form the output is in question marks. The rest of the site works fine. Any ideas what could be the problem? That page is here: http://www.liyuantheatreopera.com/zh/zaixianyuding/

    Thank you


  2. kstover
    The WP Ninjas
    Plugin Author

    Posted 3 years ago #

    Hey Chiappa,

    This is a problem with the character encoding that we used on the form databases. We've fixed this in the version we plan on releasing at the end of this month, but if you want to fix it now, and aren't afraid of editing mySQL tables, you can change all of the Ninja Forms tables in your WordPress mySQL db to UTF encoding. If you want more information on how to do this, let me know, and I'll give you some more specifics. Otherwise you can get the update when we launch it later this month.

  3. chiappa
    Posted 3 years ago #

    Thanks for the reply Kevin. Ok, that figures.. :)

    I just changed all the ninja form collations i could find from 'latin1_swedish_ci' to 'utf8_general_ci' with phpmyadmin. Looks to be working, I will confirm when fully working.

  4. chiappa
    Posted 3 years ago #

    yes, it is indeed working now!

    but there seems to be a problem using this in conjunction with qtranslate when using a landing page. submissions are redirected back to the default language.

    i would happily use the ajax submission feature if the 'Success Message' would be shown beneath the form. are there any plans to change this behavior in the future version?

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Ninja Forms
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic