Support » Theme: MH Purity lite » Child theme support

Viewing 7 replies - 1 through 7 (of 7 total)
  • Theme Author MH Themes

    (@mh-themes)

    Hi Misha77,

    thanks for using MH Purity lite.

    When you have created a child theme properly, it will be fully supported. You probably just have not added the template name (parent theme) properly in the stylesheet of the child theme.

    Hello, I am having the same problem making a child theme with mh purity lite. I have made child themes for other themes before with no problem. This time, after numerous attempts, it keeps saying the style sheet is missing. Any way to help me?

    Thanks!

    Hi Narvel99,
    I have the problem still unresolved too. I don’t know why it is marked as resolved.
    Regards.

    Theme Author MH Themes

    (@mh-themes)

    It is resolved because there is no issue. As mentioned before, when you create a child theme properly, it will work without any issues. Please keep in mind that child themes are default WordPress functionality and the theme does not affect that.

    We just even took took the time to create a child theme for testing purposes (although not necessary) and as expected, it worked immediately out of the box….

    Here are the entries in the style.css of the child theme:

    /*****
    Theme Name: MH Purity lite Child Theme
    Theme URI: http://www.mhthemes.com/themes/mh/purity-lite/
    Author: MH Themes
    Author URI: http://www.mhthemes.com/
    Template: mh-purity-lite
    Description: MH Purity lite Child Theme.
    Version: 1.0.0
    License: GNU General Public License v2 or later
    *****/
    
    @import url("../mh-purity-lite/style.css");

    As mentioned in the first answer of this thread, of course you should always make sure that the paths are correct and that you’ve added the template of the parent theme properly “Template: mh-purity-lite“. When you don’t create a child theme properly, the theme can’t help it. 😉

    Hi MH Themes Team! Yes, you are right! It was my mistake when creating child theme folder. Child theme works perfect!
    Vielen Dank!

    Okay, but just to be clear though, the problem was that when I went into Editor to copy the style.css sheet, the line with the Template info was missing (pasted below). As you can see, there is no Template line. I put in various combinations of the name, but nothing worked. I like what I’ve seen of this theme so far and was considering going premium. Hope I don’t encounter more glitches in information.

    Thanks for the info

    /*****
    Theme Name: MH Purity lite
    Theme URI: http://www.mhthemes.com/themes/mh/purity-lite/
    Author: MH Themes
    Author URI: http://www.mhthemes.com/
    Description: MH Purity lite is a clean and modern WordPress magazine theme which is perfectly suited for stylish online magazines, dynamic news websites and fancy blogs. This magazine WordPress theme can be configured within a few minutes and the theme options are fully integrated in the WordPress Theme Customizer.
    Version: 1.0.7
    License: GNU General Public License v2 or later
    License URI: http://www.gnu.org/licenses/gpl-2.0.html
    Text Domain: mhp
    Domain Path: /languages/
    Tags: two-columns, left-sidebar, right-sidebar, responsive-layout, custom-background, custom-colors, custom-header, custom-menu, featured-images, theme-options, threaded-comments, full-width-template, translation-ready, rtl-language-support
    *****/

    Theme Author MH Themes

    (@mh-themes)

    @narvel99:

    Hope I don’t encounter more glitches in information.

    What glitches are you talking about? The missing line with the template information is not a “glitch” as this information doesn’t belong in the stylesheet of a parent theme.

    It belongs only in the style.css of the child theme and you’ll need to create this stylesheet by yourself. You might want to check the codex regarding child themes, as there is an example included there: http://codex.wordpress.org/Child_Themes

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Child theme support’ is closed to new replies.