Child Theme Problems (12 posts)

  1. clevis
    Posted 2 years ago #


    I just installed a theme called Moses and I am trying to create a child theme. I've made a few customizations on the parent theme, and then realized that I needed to do those through a child theme.

    The problem is, that when I activate the child theme, it takes away my background and navigation (controlled by the ubermenu plugin).

    In my themes directory, I have a folder called Moses-child. The style.css looks like:

    Theme Name: Moses-Child
    Description: Child Theme for Moses Parent
    Author: admin
    Template: Moses

    (optional values you can add: Theme URI, Author URI, Version)

    @import url("../Moses/style.css");

    The style.css in the regular Moses theme is:

    Theme Name: Moses
    Theme URI: http://mintthemes.com
    Description: Themes for Churches
    Author: Mint Themes
    Author URI: http://mintthemes.com
    Tags: church, basic, moses

    @import "css/reset.css";

    /* import the theme css *after* the base_styles */
    @import "css/base_styles.css";

    /* font stylesheet */
    @import "css/museosans/stylesheet.css";

    Is there any reasons why the imports on the original style.css would be causing the child theme not to work?

  2. Andrew
    Forum moderator
    Posted 2 years ago #

    Try moving your child theme so it sits in this directory

  3. clevis
    Posted 2 years ago #

    Yup, it is there. The original theme is in wp-content/themes/Moses and the child is at wp-content/themes/Moses-child.

  4. Andrew
    Forum moderator
    Posted 2 years ago #

    In your child theme style.css, try lower case Moses:

    Template: moses
  5. clevis
    Posted 2 years ago #

    Well, that may have helped point to an issue. The original theme has an uppercase "M" and when I took that away just to try, it REALLY messed the site up. So, I think that the child theme is "working" however it is still not showing the background images or navigation.

    Since the original Moses style.css just has @imports, would that be causing it not to work?

  6. Andrew
    Forum moderator
    Posted 2 years ago #

    You may need to redefine CSS URLs, wherever referenced, to something more specific, like;

  7. clevis
    Posted 2 years ago #

    No dice.

    I changed all the @imports in the Moses style.css to:
    @import "/wp-content/themes/Moses/css/reset.css";
    @import "/wp-content/themes/Moses/css/base_styles.css";
    @import "/wp-content/themes/Moses/css/museosans/stylesheet.css";

    When, I activated the child theme, I still get this: http://fbcsudbury.dreamhosters.com/ (no backgroud, no nav, and crazy footer)

  8. Andrew
    Forum moderator
    Posted 2 years ago #

    Sorry I meant the URLs for the missing images.

  9. clevis
    Posted 2 years ago #

    Yeah, I'm still seeing no change. :(

    When I inspect with Firebug, it shows that the entire UberMenu pluging is not being included. Sigh.

    I've de-activated the child theme, so now the correct site is showing.

  10. clevis
    Posted 2 years ago #

    Okay, on the style.css for the child theme, I just included the other .css files that reference the background and that works.

    What I still don't see is a correct footer or navigation...

  11. Andrew
    Forum moderator
    Posted 2 years ago #

    I see this error,

    Failed to load resource: the server responded with a status of 404 (Not Found) http://fbcsudbury.dreamhosters.com/wp-content/themes/Moses-child/css/minimal.css
  12. clevis
    Posted 2 years ago #

    I think it is pulling in the css now...just not the UberMenu plugin...

Topic Closed

This topic has been closed to new replies.

About this Topic