WordPress.org

Forums

Hueman
[resolved] Child Theme or Version not working? (7 posts)

  1. dmchic
    Member
    Posted 10 months ago #

    Hi,
    I seemed to have messed something up and not sure how to fix it. After I installed the new version and created the child theme, my site seemed to have lost all of it's styling and it's just one column without any theme features.

    This is my site: http://dmdujour.com

    This is what my style.css for my child theme looks like:
    /*
    Theme Name: Hueman Child
    Theme URI: http://alxmedia.se/themes/hueman/
    Description: Sample child theme for customization.
    Author: Diem
    Author URI: http://dmdujour.com
    Template: hueman
    Version: 1.0.0
    */

    @import url("../hueman/style.css");

    /* ------------------------------------------------------------------------- *
    * Theme customization starts here
    /* ------------------------------------------------------------------------- */

    /* Global */
    .mystyle {}

    /* Tablet - 800px, 768px & 720px */
    @media only screen and (min-width: 720px) and (max-width: 800px) {
    .mystyle {}
    }

    /* Mobile - 480px & 320px */
    @media only screen and (max-width: 719px) {
    .mystyle {}
    }

    /* Mobile - 320px */
    @media only screen and (max-width: 479px) {
    .mystyle {}
    }

    I've tried deactivating all my plugins and that didn't help. Can anyone tell me how I can fix this?

  2. Alexander Agnarson
    Member
    Theme Author

    Posted 10 months ago #

    Hi - you run some type of CSS-minify option from a plugin, which is the most likely cause of the issues. Disable CSS minify from the cache plugin you use and see if it helps!

    I've tried deactivating all my plugins and that didn't help.

    I'd try again, as you may have had some browser cache stored or something. Force refresh the page with CTRL+F5.

  3. dmchic
    Member
    Posted 10 months ago #

    I just tried disabling all of my minify (JS, CSS, and HTML) settings and forcing a refresh as well as clearing all the cache but it's not working. Is there another solution I can try?

  4. Beefstick
    Member
    Posted 10 months ago #

    Just a suggestion. Try copying the css from the parent theme and pasting it into your child theme css file, except for the theme info above where it says customization starts here. Not sure if it will help but its worth a try.

  5. stephencottontail
    Member
    Posted 10 months ago #

    Did you change something since you last posted? This is what I see when I visit your site: http://imgur.com/BYiCFew. Also, you have a <script> ... </script> block in your child theme's stylesheet that shouldn't be there.

  6. dmchic
    Member
    Posted 10 months ago #

    Yes I actually did. I was toying around with my plugins and I think I found the fix. I disabled all performance settings on my cloudflare and deleted the W3TC plugin all together because now I'm sure that plugin is what caused the issue. I have since re-added the W3TC with the default settings and now configuring one by one to find out what went wrong. I will report back when I have the exact cause.

    As far as the <script> block. I think it's my featured.php file that I copied from my parent theme. I was trying to make my featured slider automatic but it doesn't seem to be working. Any suggestions?

  7. dmchic
    Member
    Posted 10 months ago #

    OK reporting back on the issue. It looks like the reason for the error was because of the minify stylesheets I manually added. After I removed all those from the CSS minify settings, I was good to go. Thank you everyone for your help on this topic!

Reply

You must log in to post.

About this Theme

About this Topic

Tags

No tags yet.