WordPress.org

Ready to get started?Download WordPress

Forums

Child Theme not linking properly, have tried EVERYTHING (7 posts)

  1. jmill621
    Member
    Posted 1 year ago #

    I'm setting up my child theme to make changes to my WP site, but no matter what I try I still get the same "This child theme requires its parent theme, Blank". Which is weird, because the styles work perfectly.

    Everything on the home page of the child theme looks the same as the parent; the only difference is that I can't navigate through links when I'm in Live Preview mode (not sure if that's just a WordPress thing).

    Can someone please tell me what a fully functioning child theme is supposed to look like?

    Here's the code to my child theme's style.css file. Everything works on the surface. The only strange thing about it is that the @import line looks to be commented out, yet still works. Not a clue why.

    /*
    Theme Name: Blank Child
    Template: lh_wordpress_blank_theme
    Version: 3.6.1
    */

    @import url('../lh_wordpress_blank_theme/style.css');

    The site is http://www.insateweb.com , if that helps at all.

  2. WPyogi
    Forum Moderator
    Posted 1 year ago #

    What is the name on the parent theme folder?

  3. WPyogi
    Forum Moderator
    Posted 1 year ago #

    Have you activated the child theme?

  4. Here's the code to my child theme's style.css file.

    Also what's the URL to that child theme? Meaning the directory name that you have that child theme in.

  5. jmill621
    Member
    Posted 1 year ago #

    The URL to the child theme is "public_html/insateweb.com/wp-content/themes/lh_wordpress_blank_theme-child"

    The child theme is not currently active but I have activated it multiple times before. It's just very annoying when every time I switch back to parents I have to reconfigure my sidebar widgets.

    I've read as many tutorials as I can get my hands on, but not one has dealt with the specific problem I'm having.

  6. jmill621
    Member
    Posted 1 year ago #

    Also, name on parent theme folder is lh_wordpress_blank_theme.

    I've tried changing both the name on the theme folder and the @import url. In both instances the styles stop working.

  7. WPyogi
    Forum Moderator
    Posted 1 year ago #

    Not all themes will work with a child theme - so that may be the problem. Where did you get the theme?

    It's really hard to troubleshoot something like this unless you have the child theme active...

    Also, parent theme settings/options don't transfer to a child theme so if that's the issue, that's to be expected.

Topic Closed

This topic has been closed to new replies.

About this Topic