WordPress.org

Ready to get started?Download WordPress

Forums

Twenty Thirteen
Child theme not inherating proper CSS (2 posts)

  1. mjcjr
    Member
    Posted 2 months ago #

    I created a style.css file in a new folder under the themes directory.
    used this code:

    /*
    Theme Name: Custom Twenty Thirteen
    Theme URI: URI to your theme
    Description: Twenty Thirteen child theme with a twist or two
    Author: Michael J. Champ Jr.
    Version: 0.0.1
    Template: twentythirteen
    */
    
    /* Imports all styles from the Twenty Thirteen stylesheet */
    @import url('../twentythirteen/style.css');

    When I activate the theme, I refresh my browser with the site and there is styling missing and the header info looks awful and the navigation is missing all styling from the css file.
    I used code inspector and see that the following is not propagating into the site.

    <h1 class="site-title"></h1>
    media="all"
    .site-title {
    font-size: 60px;
    font-weight: bold;
    line-height: 1;
    margin: 0;
    padding: 58px 0 10px;
    }
    
    <h2 class="site-description"></h2>
    media="all"
    .site-description {
    font: 300 italic 24px "Source Sans Pro", Helvetica, sans-serif;
    margin: 0;
    }
    
    <div id="navbar" class="navbar">
    media="all"
    .navbar {
    background-color: #f7f5e7;
    margin: 0 auto;
    max-width: 1600px;
    width: 100%;
    }
    
    <nav id="site-navigation" class="navigation main-navigation" role="navigation">
    media="all"
    .main-navigation {
    clear: both;
    margin: 0 auto;
    max-width: 1080px;
    min-height: 45px;
    position: relative;
    }
    localhost/media="all"
    article, aside, details, figcaption, figure, footer, header, nav, section, summary {
    display: block;
    }

    If I switch back to twentythirteen theme everything looks good.

    I even tried copying all the parent theme's css code into my child theme's css file and still has the same results.
    I'm totally confused.

  2. WPMU DEV
    Member
    Posted 2 months ago #

    Hi @mjcjr,

    Could you please share me your site link so that i can troubleshoot it?

    Kind Regards,

Reply

You must log in to post.

About this Theme

About this Topic