[resolved] Child Theme Layout Broken (Canvas) (4 posts)

  1. RefineH
    Posted 2 years ago #

    I recently got the Canvas theme from Woothemes and I'm trying to set up a child theme.

    The problem: After setting up the child theme with FTP and activating the child theme, the theme layout is broken (all of the elements are pushed together, stuff overlaps, etc) and it looks nothing like the original theme.

    The way I understood child themes to work was that the original theme would be displayed (unchanged) until I altered the style.css file in the child theme (I haven't done anything to it, except below).


    Theme Name: Canvas Child Theme
    Theme URI: http://www.refinehumanity.com/
    Description: Canvas child theme
    Author: Woo Themes
    Template: canvas
    @import url('../canvas/style.css');

    Feel free to visit the site to see the broken layout that I"m talking about.

    Things I've tried:
    Adding the folders css, styles, images, functions, include (they all came with the parent theme) into the child theme folder.
    Adding an empty functions.php file to child theme folder.
    Adding an empty custom.css file to child theme folder.

    Note: I know that WooThemes has a support forum, but I tried to make a child theme using the twentyeleven theme and the same loss of layout occurred, so I figure there's some important step in the process that I'm missing.

    I'm happy to provide any more info that I can if you guys need it.


  2. Andrew
    Forum moderator
    Posted 2 years ago #

    Your website shows this error;

    Failed to load resource: the server responded with a status of 404 (Not Found) http://refinehumanity.com/wp-content/themes/CanvasChildTheme/style.css?ver=5.1.1

  3. WPyogi
    Forum Moderator
    Posted 2 years ago #

    A standard child theme should only have the new style.css file in it to start with - then you only add other files IF you need to modify them.

  4. RefineH
    Posted 2 years ago #

    Thanks Andrew,

    I knew it was something really simple like that. The folder I had the style.css in had spaces in the name, taking the spaces out was all that I had to do to fix the reference.

    Thanks again!

Topic Closed

This topic has been closed to new replies.

About this Topic