WordPress.org

Forums

[resolved] Child theme doesn't appear in manage themes (5 posts)

  1. rwoolfson
    Member
    Posted 2 years ago #

    I have tried to create a child theme for twentytwelve exactly as prescribed:

    1. created new subdirectory /wp-content/themes/twentytwelvechild

    2. Created 'minimal' style.css file:
    /*
    Theme Name: Twentytwelve Child
    Template: twentytwelve
    */

    @import url("../twentytwelve/style.css");

    3. FTP'd this file into the above subdirectory

    But when I look in 'manage styles' the child theme is not there. What am I doing wrong?

  2. leejosepho
    Member
    Posted 2 years ago #

    1. created new subdirectory /wp-content/themes/twentytwelvechild

    Does that mean your simply created a folder named "twentytwelvechild" inside the pre-existing public_html/wp-content/themes/ directory?

  3. WPyogi
    Forum Moderator
    Posted 2 years ago #

    It looks like what you have done is correct - but be sure that you've cleared all caches (browser and site and server). Was the new file created in a plain text editor (not Word) and saved as .css ?

  4. rwoolfson
    Member
    Posted 2 years ago #

    I've resolved it, and I'm embarrassed by the explanation but I'll mention it in case anyone else is equally stupid. I originally uploaded wordpress to the wrong directory but omitted to delete the files when I finally put it in the correct place. I've been working with the original incorrectly located wordpress files so, of course, the child theme did not appear. I will now delete the original files.

    Thank you for responding and I apologise again for my stupidity.

  5. WPyogi
    Forum Moderator
    Posted 2 years ago #

    LOL - no problem - in fact, someone else had a very similar issue a few days ago, so don't feel bad about it :). Sometime it just takes posting here to suddenly realize what the problem is.

Topic Closed

This topic has been closed to new replies.

About this Topic