WordPress.org

Forums

Child theme broken/missing template (7 posts)

  1. Pluckedwanderer
    Member
    Posted 1 year ago #

    Hi,

    Obviously I have no idea what i'm doing and I've been trying to get this right for a while now with no luck. I have created a leaf-child folder in my wp-content/themes. I have added the style.css from it's parent theme (I copied and pasted from the parent theme. I tried just creating a style.css and using the `/*
    Theme Name: Leaf
    Theme URI: http://example.com/
    Description: Child theme for the Leaf theme
    Author: Your name here
    Author URI: http://example.com/about/
    Template: Leaf
    Version: 0.1.0
    */

    with @import url("../leaf/style.css");

    but that still hasn't worked.
    I also added an archive.php folder

    It says Broken Themes

    The following themes are installed but incomplete. Themes must have a stylesheet and a template.

    Name Description
    Leaf Template is missing.

    What am I doing wrong??

    pluckedwanderer.com

  2. Use a lowercase 'L' in the template line.

  3. Pluckedwanderer
    Member
    Posted 1 year ago #

    haha, thanks

    If I need to do any changes like adding a footer.php, do I just add it to the child theme in wpcontent/themes/leaf-child and change it there?

  4. Yes. :)

  5. Jose Monte
    Member
    Posted 1 year ago #

    Edited:
    I got a similar problem, but in my case, the Child Theme was missing the: Template: Name in the style.css

  6. Jose Monte
    Member
    Posted 1 year ago #

    Sorry, my Child Theme was missing the: "Template: Name" in the css file.

  7. sarankumar
    Member
    Posted 1 year ago #

    @Jose Castaneda,
    wow :D thank you

Topic Closed

This topic has been closed to new replies.

About this Topic