Support » Installing WordPress » Child Site links incorrectly

Viewing 2 replies - 1 through 2 (of 2 total)
  • his site has a completely different database and install, making it literally its own site.

    Er, unless you created an add on domain it’s not!! – if all you’ve done is to manually create a folder & then stick a site in it, then that’s not the same thing (you’d only do that if for example, you had a site made in Joomla & then you wanted to add a wordpress blog to it – or if you wanted to add on a directory script that runs in it’s own folder, etc)

    What’s also probably happening (or will happen unless you fix it) is that it is probably confusing the search-engines too – they see that sub-folder & will naturally think it’s just a part of your existing site. They will then index it as being part of the other site – meaning you are going to have MAJOR SEO trouble, 404’s and many re-directions to do unless you change it ASAP.

    Here’s what to do.

    1/ Delete the site you installed in the sub-folder (you could compress it & download it to your PC if you need to have it backed up, but unless you’ve done work to it then it’s probably better to start fresh)

    2./Go to your CPanel, and create a new “add on” domain. Doing this will then create a new folder that sits within your root folder (it will look the same as if you’d manually created a folder there…but whilst it might look the same, it’s not the same as just creating a new folder…..)

    3./ Install wordpress into that new addon domain folder. Just upload the wordpress 3.3.2 zip file & unzip it, then delete the wordpress zip file as it’s not needed anymore. Once you’ve unpacked wordpress you will see some folders and also underneath them you’ll see some files, including wp-config-sample.php. Go to step 4

    4./ Add the new site’s DB details into wp-config-sample (plus also add the DB username details, password details, and then go down the page & then add the 8 “authentication and salt keys” – there’s a link URL provided within wp-config-sample.php telling you where to get them – go there, and copy and paste each of them into wp-config-sample.php, one by one. Press save & close wp-config-sample.php

    5./ Re-name wp-config-sample.php to wp-config.php and press save


    You may need to check your DNS settings for your domain name, just to make sure it’s pointed to the right place etc.

    Once you’re sure that it has fixed the problem then I’d also suggest you re-create sitemaps for both sites, and submit them again ASAP – hopefully this will help “flush out” some of the wrong links, and will also help get the correct links indexed quicker.

    You may also need to do some re-directions if you notice you’re getting a lot of 404’s because of the previous error… if so, you could give the “redirection” plugin a go, it’s very easy to use too (or you can do redirects manually via the htaccess file).

    Hope this helps.
    Cheers, Karen


    Thank you so so so very much. You cleared some things up for me and helped me understand. Thanks!


Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Child Site links incorrectly’ is closed to new replies.