• Resolved MisterZookeep

    (@misterzookeep)


    This is more of a bug report than a support request. The only responses we’ve gotten to support requests were that we only get support if we offer unlimited unsupervised access to our site.

    When running clone operations, we get various failures depending on the version of mainWP and mainWP child. This is the latest bug. It is claims all of our sites are exactly 877MB (they are not all be the same size), then returns a series of contradictory messages, all with unhandled errors produced by the plugin:

    13:51:59 This is a large site (877MB), the restore process will more than likely fail.
    13:52:14 Creating backup on %1$s expected size: %2$dMB (estimated time: %3$d seconds)

    13:52:25 Creating backup on %1$s expected size: %2$dMB (estimated time: %3$d seconds)

    13:52:39 This is a large site (877MB), the restore process will more than likely fail.
    13:52:43 Creating backup on %1$s expected size: %2$dMB (estimated time: %3$d seconds)

    13:53:41 Child plugin is disabled or the security key is incorrect. Please resync with your main installation.
    13:53:43 Backup created on %1$s total size to download: %2$dMB
    13:53:43 Downloading backup

    13:53:52 Backup created on %1$s total size to download: %2$dMB
    13:53:52 Downloading backup

Viewing 5 replies - 1 through 5 (of 5 total)
  • Hi @misterzookeep, thanks for reporing this problme. We fixed this and the next official release will contain fix for this problem.

    Thanks,
    Bogdan R.

    There are additional issues. One time, we can clone sites using the clone from source feature. The next time, we cannot clone from source, but can from backup.

    Later, we can clone from source no problem.

    Then the next time, we cannot clone from source or backup. When we try to backup, we get timeout failures where in earlier versions we could easily backup.

    The system does not seem to remain stable from version to version, and costs a lot of time trying to discover what parts work in the current version. Currently, having just synched a child site within five minutes, the backup dialogues says it cannot find the child plugin on the site that was just synched via the child plugin.

    For another site, synched within 60 seconds of running the synch feature on the dashboard, returns the following error:

    17:16:13 Child plugin is disabled or the security key is incorrect. Please resync with your main installation

    We get this error on any site we try to clone from, and it cannot be a correct error because we updated, revalidated and synced sites on both sides of the clone operation before attempting to clone.

    17:29:15 Child plugin is disabled or the security key is incorrect. Please resync with your main installation.

    When we visit the help page for backup, we see a long list of configuration settings required in our WordPress config and php.ini, but nothing in the ambiguous error message tells us which of any of those settings might be viable for a site that, at the same time, reportedly does and does not have the child plugin.

    Are you saying the entire clone feature is broken and won’t be working until the next release?

    Further efforts to find a way around broken backup feature and broken clone feature just lead to more problems. We deleted and reinstalled the mainWP child plugin.

    Upon reinstalling the plugin wp-admin/options-general.php?page=mainwp_child_tab is not found.

    Hi @misterzookeep, can you please check if the MainWP Child 4.1.1 (along with Dashboard 4.1.2) solves the problem?

    Plugin Author mainwp

    (@mainwp)

    Hi @misterzookeep, I assume that the problem got solved with the latest update so I will go ahead and mark this request as resolved.

    If that is not correct, please feel free to open a helpdesk ticket so we can look into this again.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.