Support » Plugin: Toolset Types - Custom Post Types, Custom Fields and Taxonomies » Child post type – Checkbox issues

  • Resolved sthubbins

    (@sthubbins)


    Hi,

    I have created a post type (A) with an associated field group that contains checkboxes along with other field types. I have another post type (B) which is associated with a different field group and is set as a child of post type A.

    When creating a new post of type A and before setting any data in the child post field group the checkboxes will save on update as expected (both checked and unchecked). But if any data is set in the child post fields and you click update then checkboxes always save as unchecked. The issue does not appear to affect any other field types in either post group except checkboxes.

    Again if the child post data is removed then checkboxes will save as expected.

    Can you help as to whether this is an issue with the setup or if their is a bug within the plugin?

    Thanks!

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support Beda

    (@bedas)

    I confirm this happens.

    It was as well a BUG in the 3.x releases, but has not been pushed to this branch.

    I will ask the developers to fix it, thanks for the heads up.

    Hi Beda,

    Thanks for the reply.

    Just to confirm, this has been fixed in the pro version is that correct?

    Do you have an ETA for an update that would include a fix for this on the free version?

    Thanks
    Darren

    Plugin Support Beda

    (@bedas)

    I apologize, I was confused, I thought it is something I knew from the Pro version, but this new and different actually.

    I anyway reported it already to the Developers, and will feedback here as soon I hav some news about it.

    Plugin Author Christian

    (@christianglingener)

    Hi Darren,

    thanks for reporting the issue. We released Types 2.3.3 to fix it.

    Here the direct link:
    https://downloads.wordpress.org/plugin/types.2.3.3.zip

    Best,
    Christian

    Hi Christian,

    Thanks for the quick attention. I can confirm this has resolved the issue for our development.

    Appreciate the support!

    Darren

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Child post type – Checkbox issues’ is closed to new replies.