Support » Themes and Templates » child page not showing in nav menu

  • I’m using the Pilcrow theme and when I add a child page it is not showing up in the navigation menu. If this is part of the theme, is there a workaround? Or if it is some dumb thing I forgot to do, please tell me! I’m not any kind of expert here! Temporary site is at http://cwahawaii.org/gf/ and there is a child page under Benefits that is not showing. Thanks for your help!

Viewing 11 replies - 1 through 11 (of 11 total)
  • It looks like the theme comes with custom menus. Maybe trying setting up the menu that way.

    Go to Appearance > Menus and create a new menu.
    Add the pages that you want and save it.
    You might also have to select a theme location.

    Thanks Christine – I tried that, but it just put the child page label next to the parent page menu item horizontally. No place to ‘select a theme location’ that I can see.

    So, I tried installing a plugin called Menu but couldn’t see how to customize that one either. So, problem still exists. Any other ideas?

    I figured it out – changed a filter in the theme options from ‘1’ to ‘3’ and voila!

    Good to know… I totally forgot about theme options.

    OK, now I’ve got a new issue – but can’t figure out how to write a new topic!. I used the ‘More’ tag in a couple of posts but when I click “continue reading” on the page it goes to a 404 cannot find… page. How do I get the More tag to work in Pilcrow?

    I just figured out how to write a new topic, so I’m repeating this one in a new post on the Themes Forum. sorry!

    elijacobs

    (@elijacobs)

    Hi “jlevant”

    I have the same problem that you mentioned 6 months ago – child pages not appearing in navigation menus. I see that they are working for you on http://cwahawaii.org/gf/
    What’s the secret?
    it looks like ya used a plugin – is that right?
    does that mean that it won’t work for me on wordpress.com?

    tia for your help,
    Eli in Jerusalem

    jlevant

    (@jlevant)

    Eli, if you look at my 3rd comment above, you’ll I figured it out by editing the theme options page – changed the filter from 1 to 3 it seems (using editor>theme options.php). So long ago I can’t remember other than reading what I wrote. Good Luck.

    elijacobs

    (@elijacobs)

    yup – I saw that comment. But when I go to Theme Options all I see are options for the layout, meaning the location of the sidebar. There is no “Filter”.
    Is it possible that it is only in wordpress.org and wordpress.com?

    Hi Eli,

    Not sure if you’ve had any luck with this, but I think I’ve figured it out. The filter is actually in the editor > functions.php file. If you find this string:

    function pilcrow_page_menu_args( $args ) {
    $args[‘show_home’] = true;
    $args[‘depth’] = 1;
    return $args;

    Just change the “1” to however many pages deep you’d like to go.

    Hope that helps.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘child page not showing in nav menu’ is closed to new replies.