Support » Fixing WordPress » child css saves but no change in parent

  • Resolved orsan

    (@orsan)


    Hi,
    Created a child theme:
    /home2/cvlangua/public_html/wp-content/themes/twentyfourteenchild/style.css
    /* Theme Name: twentyfourteenchild Theme URI: http://cvlanguage.com/ Description: twentyfourteen child theme Author: Morgan Thomas Template: twentyfourteenchild */ @import url(‘../twentyfourteen/style.css’);
    }
    activated twentyfourteen and then child theme
    in each case, using jetpack edit css
    input code below and saved.

    .entry-header-full,
    .entry-content-full,
    .entry-summary-full,
    .entry-meta-full {
    margin: 0 auto;
    max-width: 1110px;
    width: 95%;
    }
    with activated twentyfourteen, preview no change.
    with activated child, preview was of twentyfifteen???
    What am I missing here?
    Thanks

Viewing 12 replies - 1 through 12 (of 12 total)
  • Your site is showing that it’s running the TwentyFifteen theme. What does your ‘Themes’ panel in the admin area say is the active theme?

    Hi catacaustic,
    Suddenly twentyfifteen has moved ‘automatically’ into first place and shows ‘active’.
    thanks for responding

    If that semes to happen “automatically”, the only thing that I can think of is that there’s some sor to fissue with your chosen theme, and it’s reverting back to the system default theme.

    What happens when you activate the theme that you want?

    It appears but with no change.

    Your site is still running the Twentyfifteen theme, so it looks like there is something wrong with the theme that you’re trying to activate. I’d probably start with looking at the style.css file and check for anything there that’s not looking right, and then see if there’s any errors in the functions.php` file as well. In order to figure out what coudl be wrong we really would need to see all of the code that you’re using.

    It appears to be running the Twentyfifteen only when I activate the child css and edit it. Otherwise, if I only activate Twentyfourteen, and test it, it’s fine. There has been no problems with it until I opened the child theme, so it may be something wrong with the configuration of the child theme which I installed just minutes before all of the ‘non response’ started happening.

    That’s what I was asking. To figure out any problems we’d need to see the code for the child theme. Without that it’s imposible to even guess what the problem could be.

    Oh, and if you’re going to paste lots of code, you should use Pastebin or something similar to save the space on here. 🙂

    when I activate the child theme for fourteen, and edit css, I get only the following:

    /*
    Welcome to Custom CSS!
    To learn how this works, see http://wp.me/PEmnE-Bt
    */

    Then when I click editor, the Twentyfifteen shows up.
    I think I need to delete the child theme and recreate it with my host to see if for some reason it may be attaching itself to Twentyfifteen in the host directory. The only problem with that idea is that twentyfifteen should show some changes, and as far as I can see there are none, although I am not really familiar with the theme. In any case, I will try the redo tomorrow since it is 1:18am this part of the world and I am falling asleep on the keyboard. Thank you for your help so far, which has led to the idea of rebooting 🙂
    I hope you will be available at a later date.
    Thanks – really like your photo.

    Looking at that… Is your site on WordPress.COM? if it is, you’ll have to as at their support forums.

    WordPress.com and WordPress.org

    If it’s not, I’m really not sure why you’d be seeing that sort of message, as it looks like it’s really geared towards the .com site.

    I’m on WordPress.org with bluehost.
    Very few problems in the past many years, until I started to get ‘creative’.

    Solved: recreating child theme, then setting up full screen display on publication and widening visual editor to fit your display screen

    Contents
    Above: Initial feedback and help
    Below:
    1. How to create a child theme
    2. Creating a full width theme on display screen
    3 Change visual editor width to match

    How to create a child theme in your host (not WordPress), and create a child theme style.css so as to not lose changes due to regular theme
    upgrades in the WordPress account.
    An excellent blog on how to initially set up a child theme. The following link Creating a WordPress child theme on Bluehost (although I think something like it would work for most hosting sites)
    http://www.anthonybaldor.com/creating-a-wordpress-child-theme-on-bluehost/
    It is very detailed. The best I’ve found. One thing to take note of: when editing the new blank file for the child style.css, be sure to use the edit button at the top. Do not right click on the file and try to edit that way.

    Due to some problem (as yet undefined), I decided to delete the previous child theme style.css and recreate it following the link below, But the step by step above got me started when I was totally lost.
    https://www.webhostface.com/kb/knowledgebase/how-to-make-wordpress-twenty-fourteen-theme-full-width/
    According to this, you should also add a function.php file alongside the child style.css, and insert the following code in that function.php file

    Code for the child style.css tailored to your own details

    /*
    Theme Name: Twenty Fourteen Child
    Theme URI: http://cvlanguage.com/twentyfourteen-child/
    Description: Twenty Fourteen Child Theme
    Author: Morgan Thomas
    Author URI: http://cvlanguage.com
    Template: twentyfourteen
    Text Domain: twentyfourteen-child
    */

    I also put into the child style.css the many lines of code from the full width screen display below.

    .site {
    background-color: #fff;
    max-width: 100%;
    position: …
    etc. not re copied here from below.

    Secondly, the code to put into the function.php file:

    <?php
    add_action( ‘wp_enqueue_scripts’, ‘theme_enqueue_styles’ );
    function theme_enqueue_styles() {
    wp_enqueue_style( ‘parent-style’, get_template_directory_uri() . ‘/style.css’ );
    }
    ?>

    Works great with the child theme and the function.php files together.

    2. Creating a full width theme on display screen
    How to make WordPress twentyfourteen theme full width on publication
    Take a look at this reference: WordPress: Changing the Width of Your Post Editor https://www.webhostface.com/kb/knowledgebase/how-to-make-wordpress-twenty-fourteen-theme-full-width/
    Shows how to change the style.css file in the original twentyfourteen theme itself (in wp-content/themes/twentyfourteen folder) on your hosting site.

    However, since I had created a child style.css in a new twentyfourteen-child file on my hosting site, I then added the following code (tweaked) from the article, and added it to the child style.css after it was activated under appearances on the WordPress.org editing site. Needs some adjusting to get the size you really want.

    .site {
    background-color: #fff;
    max-width: 100%;
    position: relative;
    }

    .site-header {
    background-color: #000;
    max-width: 100%;
    position: relative;
    width: 100%;
    z-index: 4;
    }

    .site-content .entry-header,
    .site-content .entry-content,
    .site-content .entry-summary,
    .site-content .entry-meta,
    .page-content {
    margin: 0 auto;
    max-width: 65%;
    }

    .comments-area {
    margin: 48px auto;
    max-width: 65%;
    padding: 0 10px;
    }

    .site-content .entry-meta {
    background-color: #fff;
    margin-bottom: 8px;
    max-width: 100%;
    }

    3. Change visual editor width to match

    I found 2 methods:

    1. Paul Bearne (this method worked fantastically the first time and then I could never get it to work again. You might give it a try.

    Change width of visual editor in fullscreen mode
    https://wordpress.org/support/topic/change-width-of-visual-editor-in-fullscreen-mode?replies=5\

    You can set this line of code in the main theme’s function.php just above the last ?>

    set_user_setting( ‘dfw_width’, 1000 );

    My comment: This can be done in the WordPress editing page under Appearance, be sure your theme is activated, then go down to editor at bottom of appearance an find the function.php and insert it.
    Will be changed next time your theme is updated by WordPress. Best way with child theme. Under Appearance, be sure the child theme is activated.

    2. This is a great workaround:
    WordPress: Changing the Width of Your Post Editor
    https://generatepress.com/forums/topic/change-width-of-visual-editor/

    Comment by Anja: I think I found a solution that is working for me.
    I put my whole content in tables now. You can resize them to your liking and work in the same size the container of my actual website will be.

    My comment: A work around requiring no programming. Just set up a table with a minimum of 2 cells (no height necessary) even if you plan on using only one. It can be resized in the editor. Or, you can make it only 1 cell with at least 100 height (otherwise, it disappears when you try to write something inside). To change width and height, put your cursor in the table, click on Table again, and on the edit bar, select table properties, set width to your desired length,, border if you want it, and alignment.

    Happy blogging

    Did quite a lot of researching on setting up child theme, displaying full screen with twentyfourteen, and have resolved all except for actually editing in full screen.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘child css saves but no change in parent’ is closed to new replies.