Support » Plugin: WooCommerce » Checkout – Place order grayed out & loading eternally

  • Resolved ilya12



    Can anyone help. I have a site with customized theme and with woocommerce 2.0.8, and I cannot get the checkout page to work properly.

    You can place items in the cart and fill out all of the info but the place order section of the page stays grayed out and the little wheel keeps spinning.

    All the short codes are in place on each page.
    I have tried to switch to TwentyEleven theme with no success.

    It is noteworthy that everything works if I am logged in on the site. The problem exists only for unregistered users. And I guess it has something to do with this ‘create an account’ checkbox in the middle of the checkout page.

    NB: If I delete the following line:

    <script type='text/javascript' src=''></script>

    from page source code, error disappears.

    Thanks in advance!

Viewing 10 replies - 1 through 10 (of 10 total)
  • Same exact problem on my site. We don’t care about creating an account so it the line of code you have taken out that line that let’s them create an account?

    Something on your site is interfering with WooCommerce Javascript Ajax requests. Instead of WooCommerce returning the expected snippets of HTML from Ajax, what is returned is a complete HTML document, which indicates interference of some sort.

    Try switching to TwentyTwelve theme and see if checkout works. If not, disable all plugins except WooCommerce and try again.

    Fixed it!

    All I’ve done:

    1. Deactivated all my 25 plugins (including woocommerce itself)
    2. Activated them ALL back in packs of 3.

    So just deactivated all the plugins and activated them all again and the error is gone!

    Don’t ask me why, I’ll never know!


    I’m helping out a friend who got a messed up woocommerce shop setup through a guy. The checkout didnt work on some devices like ie en android. Now i found out it doesnt work when you are logged out of wordpress. So i did everything i could do, tried every solution. I started out with a completely outdated non responsive version of mayashop and wordpress and pretty much every plugin. Updated eventually downgraded from 3.8 to 3.6, added and removed tags in the head, deactivted and activated all plugins in many fashion, i dont seem to find the problem in firebug, no permalink problems, no shortcode problems. Settings are all okay as ive configured many woocommerce shops. PErhaps deleting all the products and woocom. data from the database is the only solution, hope someone can take a look. thanks.


    Did you try to disable “ENABLE AJAX add to cart buttons on archives”? I have exactly the same problem, but i can not reproduce your issue on my own site.

    I have installed WordPress 3.6.1. Some browsers freeze on the check-out page.

    See also:

    Please, can you help us?



    i’m getting a 401 “autorization required” when i load your checkout page on the file wp-admin/admin-ajax.php

    Moderator Andrew Nevins


    WCLDN 2018 Contributor | Volunteer support

    @nldees can you start up a new thread with more description of your issue?

    @nldees yeah i already disabled ajax add to cart on archives didn’t do it. And haven’t noticed the 401 yet, but i do see different results in different browser versions (it works or the spinner is stuck) however the problem only occurs on IE and chrome.

    The allocated php memory is 40mb but i don’t believe that’s the issue. I’m thinking i might have to flush the database from all woocommerce tables and see if adding woocommerce and products again does the trick, because eventually the database and products have been updated through wordpress from 1.6 to 2.0.

    Please let me know where you start the new thread as i’m really frustrated on this problem

    I was also having the the issue of <b>Your Order</b> area on checkout page has been greyed out (disabled).
    I got my error fixed by enabling the display errors on and enabled all the undefined and warnings.
    Got all the errors fixed.
    And it fixed the checkout page.
    Don’t know it might be the headers already sent error or something else.
    Thought it might help someone.

    Ultimate Peter


    Hello, I just researched this problem for two days and am trying to pass on my solution, because it was super frustrating:

    After entering City, State, Zip: Ajax spinner would spin indefinitely, even with no payment gateways, only cheque!
    Only for people not logged in to site. Worked fine for me logged in.
    Also, cart widget wouldn’t display products.

    I followed every piece of advice I could find and the following didn’t work:
    -Disable all plugins except woocommerce. (including fedex and payment gateway)
    -Disabled Ajax add button
    -Tried other themes, same thing
    -Checked all page names, shortcodes, and made sure they were appropriate parent/child.
    -Increased memory to WP and PHP to 128mb.
    -I didn’t un-force https at checkout… Um, because that’s crazy.
    -Turned off all shipping and tax.
    -Made sure my Site URL and Home URL were matching on the WP General Settings.

    I had WP All-in-one Security plugin installed…
    Now, even though I had it disabled:
    It had left behind some code in my .htaccess file.
    I don’t know how I even came across it (while I was looking for some other config file I think). So, I got rid of the code in there for some of the security stuff and it worked again!


Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Checkout – Place order grayed out & loading eternally’ is closed to new replies.