Support » Plugin: WooCommerce Blocks » Checkout phone field missing.

  • Resolved Hash2k

    (@hash2k)


    Hello,

    I am using woocommerce block for checkout and I want to make the phone number mandatory.

    Even if I set the phone number optional or not, active or not, the field is missing from the form.

    I am using Astra theme.
    As you suggested in the other topic ( https://wordpress.org/support/topic/missing-checkout-phone-field/ ) I also tried the Storefront theme but I got the same result. Not working.

    I am using the plugin Version 3.6.0.

    LE: Also the line and the checkbox “Use same address for billing” are missing.

    Thank you,
    Hash2k

    • This topic was modified 1 month ago by Hash2k.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support wpnomad

    (@wpnomad)

    Hi there,

    It’s odd that you’re not seeing the phone number on the checkout block, even with the Storefront theme. I suspect a plugin might be conflicting on your site since we’re not able to reproduce the issue on our test sites.

    This kind of problem is usually caused by either a conflict with your theme or with another plugin.
     
    The best way to determine this is to:

    • Temporarily switch your theme to Storefront
    • Disable all plugins except for WooCommerce and WooCommerce Blocks
    • Repeat the action that is causing the problem

    If you’re not seeing the same problem after completing the conflict test, then you know the problem was with the plugins and/or theme you deactivated. To figure out which plugin is causing the problem, reactivate your other plugins one by one, testing after each, until you find the one causing conflict. You can find a more detailed explanation on how to do a conflict test here.

    Do let us know how that goes and if you need any further help from us.

    Plugin Author Nadir Seghir

    (@assassinateur)

    Hey!

    The phone number field and “Use same address for billing” checkbox won’t show up if your shipping method is not setup.

    Can you confirm that you have shipping enabled?

    Plugin Support zdenys

    (@zdenys)

    hello @hash2k!

    We haven’t heard back from you in a while, so I’m going to mark this as resolved – if you have any further questions, you can start a new thread.

    Cheers!

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.