Support » Plugin: WooCommerce » Checkout page: no “Ship to a different address?”

Viewing 12 replies - 1 through 12 (of 12 total)
  • Caleb Burks


    Automattic Happiness Engineer

    Go to WooCommerce > Settings > Shipping > Shipping Options and make sure you don’t have the “Force shipping to the customer billing address” setting selected.

    Thanks for replying, Caleb. No that setting isn’t checked.

    I’ve set up a completely new site using twentysixteen theme and woocommerce plugin only with all default settings and one product, here

    It shows the same behaviour.

    Caleb Burks


    Automattic Happiness Engineer

    Do you have shipping enabled at all? Go to WooCommerce > Settings > General and make sure you don’t have shipping disabled.

    Also – if the products in the cart are virtual then you won’t have a shipping section.

    Shipping not disabled (all settings at default), products not virtual.


    Can provide login.

    ### WordPress Environment ###
    Home URL:
    Site URL:
    WC Version: 2.6.4
    Log Directory Writable: ✔
    WP Version: 4.6
    WP Multisite: –
    WP Memory Limit: 256 MB
    WP Debug Mode: –
    WP Cron: ✔
    Language: en_GB
    ### Server Environment ###
    Server Info: Apache
    PHP Version: ❌ 5.4.45 - We recommend a minimum PHP version of 5.6. See: How to update your PHP version
    PHP Post Max Size: 64 MB
    PHP Time Limit: 30
    PHP Max Input Vars: 1000
    cURL Version: 7.19.7
    NSS/3.21 Basic ECC
    SUHOSIN Installed: –
    MySQL Version: ❌ 5.5.48 - We recommend a minimum MySQL version of 5.6. See: WordPress Requirements
    Max Upload Size: 64 MB
    Default Timezone is UTC: ✔
    fsockopen/cURL: ✔
    SoapClient: ✔
    DOMDocument: ✔
    GZip: ✔
    Multibyte String: ✔
    Remote Post: ✔
    Remote Get: ✔
    ### Database ###
    WC Database Version: 2.6.4
    woocommerce_sessions: ✔
    woocommerce_api_keys: ✔
    woocommerce_attribute_taxonomies: ✔
    woocommerce_downloadable_product_permissions: ✔
    woocommerce_order_items: ✔
    woocommerce_order_itemmeta: ✔
    woocommerce_tax_rates: ✔
    woocommerce_tax_rate_locations: ✔
    woocommerce_shipping_zones: ✔
    woocommerce_shipping_zone_locations: ✔
    woocommerce_shipping_zone_methods: ✔
    woocommerce_payment_tokens: ✔
    woocommerce_payment_tokenmeta: ✔
    MaxMind GeoIP Database: ❌ The MaxMind GeoIP Database does not exist - Geolocation will not function. You can download and install it manually from to the path: . Scroll down to \"Downloads\" and download the \"Binary / gzip\" file next to \"GeoLite Country\"
    ### Active Plugins (2) ###
    WooCommerce PayPal Express Checkout Gateway: by Automattic – 1.1.2
    WooCommerce: by WooThemes – 2.6.4
    ### Settings ###
    Force SSL: –
    Currency: GBP (£)
    Currency Position: left
    Thousand Separator: ,
    Decimal Separator: .
    Number of Decimals: 2
    ### API ###
    API Enabled: ✔
    ### WC Pages ###
    Shop Base: #4 - /shop/
    Basket: #5 - /basket/
    Checkout: #6 - /checkout/
    My Account: #7 - /my-account/
    ### Taxonomies ###
    Product Types: external (external)
    grouped (grouped)
    simple (simple)
    variable (variable)
    ### Theme ###
    Name: Twenty Sixteen
    Version: 1.3
    Author URL:
    Child Theme: ❌ – If you're modifying WooCommerce on a parent theme you didn't build personally
    then we recommend using a child theme. See: How to create a child theme
    WooCommerce Support: ✔
    ### Templates ###
    Overrides: –
    Caleb Burks


    Automattic Happiness Engineer

    Can’t provide a login here, but you can screenshot your settings.

    Could you screenshot your settings at WooCommerce > Settings > General, and WooCommerce > Settings > Shipping > Shipping Options? Then post links to the screenshots here. A screencast could also work.


    WooCommerce > Settings > General –

    WooCommerce > Settings > Shipping > Shipping Options –

    Caleb Burks


    Automattic Happiness Engineer

    Hmm, super strange.

    See if this conditional is failing:

    Have you used this filter: ?

    Maybe re-save all settings pages as well just to be sure.

    I’ve re-saved all the settings: no change.

    Are you asking me to debug the php code? I don’t know how to do that.

    Caleb Burks


    Automattic Happiness Engineer

    There’s not much more I can do here though. I can’t replicate this issue, and if this were truly a bug in WooCommerce core there would be hundreds of posts here about it.

    You either have something wrong with your settings, or the code as been tampered with in some way. Shipping is appearing as disabled at checkout.

    Recently had this problem after the WP update, but after researching and almost giving up, discovered had a premium shipping plugin that hadn’t been updated. (The update notices don’t show up on some paid plugins, have to manually manage them.)

    From all my tests in search of the problem, it seemed it was some setting having to do with shipping, so review all your ship settings maybe.

    Shipping Methods.

    I didn’t have any Shipping Methods set up.

    Thanks for all your help. All good now.

    Some themes STILL need some help, fixed with filter

    add_filter( 'woocommerce_cart_needs_shipping_address', '__return_true', 50 );

    • This reply was modified 4 years, 4 months ago by nodwsp.
Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Checkout page: no “Ship to a different address?”’ is closed to new replies.