Support » Plugin: WP eCommerce » Checkout (Oops, there is nothing in your cart.)

  • Resolved fischkim

    (@fischkim)


    Hello,

    After adding a product to my cart, I receive a message within my “Checkout” page: Oops, there is nothing in your cart.

    I am still editing/organizing the “Shop” page; however you can view a list of products here; http://happyfaceapparel.org/products-page/girls/

    As you can see, when you “Add To Cart”, nothing appears in the Checkout. Logged in as an Admin, everything seems to work fine. However, when opened in a separate browser (not logged in), I receive this error message.

    Has anyone else run into this issue? If so, I’d appreciate your help!!!

    Thank you! I look forward to hearing from someone.

    Kim

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Mihai

    (@misulicus)

    Hey there,
    I just tested and it worked fine.
    The sidebar widget did not got updated on its own however.
    That could be something with your theme. Try changing to a default theme like 2010.

    Regards

    I’m having this same problem. When I’m logged in as admin I can checkout completely.
    I have tested on different browsers from different computers and when I’m not admin I receive the error message “Oops there is nothing in your cart.”

    http://makeamcilrath.com/?page_id=145

    Please help! Thank you!
    Jason

    Jason, I experienced the same result as Mihai did with my site. I added a product to your cart, and it worked fine. I was able to see the product in your checkout.

    I’ve also tried testing my cart on different browsers/computer… and still no luck.

    Does anyone know why we are having these varying results?

    Thank you!

    Kim

    Kim,
    How frustrating! I visited your site using a Chrome browser. I was able to add items to my cart, view my cart and start the checkout process without a problem.
    For money’s sake I am doing a hosted WP site through godaddy. I called their support line and the CS rep was also able to access everything just fine on my site. However, I’ve tried nearly everybody in my office and none of them are having luck.
    Not sure what to do because I love the options of this plugin, but I need this thing up and running a week ago.
    BTW–love your shop.
    Thanks!
    Jason

    Hi Jason,

    Thank you for the message and for contacting support (my site is also set up through godaddy). This is a very strange (and frustrating) situation we’re in!

    I’ve tried clearing my flush, browsing data, cookies, incognito mode, etc… but no luck. It’s possible we messed something up while we were working on our site, and now there’s a bad cookie (or something) on our computers and any other machine we’ve tested the site on.

    Good news is, the Checkout seems to work on any computer that has not had access to the site (prior to the unknown mess up).

    I wish I had a better answer/solution. I’ll keep you posted if I figure out how to fix the “broken” computers.

    Thanks again!

    Kim

    Kim,
    Some stuff to report (sorry it’s lengthy):

    I’ve been testing out the “checkout” process on 5 different machines now. 4 of them worked earlier today and now none of them will go through the checkout process of my site.

    This is what I did next:
    Deactivate all of my plugins. Flush the cache for the WP site. Changed to the default theme. Reactivated plugins. Cleared the caches and history on: Chrome, IE, Firefox and Safari. Opened a new window in each browser and an “incognito” window for each browser.

    What happened? Nothing–nearly every window displayed something different. My theme was lost, my customizations were lost and none of my links would work–nothing I did helped.
    I called GoDaddy again. This time I got someone who was really helpful. It took elevating my ticket (and 45 minutes of hold time) to get it figured out. My site is now back up but none of the plugins are active.

    I started by reactivating Wp e-commerce. Everything worked fine for the first attempt (I was able to add something to the cart, checkout and enter the correct information and I was able to do it in each of the 4 browsers). Bad news–after attempting it once, it went back to being broken and started giving me the more complex problems again.

    I have since completely removed WPEC from my plugins list and have activated my remaining plugins one at a time (about every 15 minutes). I also verify on various machines and browsers that I am seeing the same results for each reactivated plugin. Everything is just peachy now (except for the fact that I don’t have a shop).

    So–because between our somewhat limited knowledge/forum searching and the advanced hosting specialists at GoDaddy this is still broken, I would say the developers need to look into it. I really don’t think there is any thing you can do to fix it.

    I agree with you that checkout seems to work on a computer that did not have access to the site during the mess up, but I’m not sure what’s causing the mess up, because I’ve had computers that did work stop working on their second and third attempts.

    If I hear anything else or discover a better solution (which giving up is not really a solution) 🙂 I’ll let you know. For now I’m gonna check out some other ecommerce plugins.

    Best of luck–keep me posted if you discover anything earth shattering!
    Thanks
    Jason

    Jason, thank you very much for your thorough response! My next step, was going to be deactivating plugins etc etc etc. I was hesitant to do that though, in fear things would be lost and messed up (similar to what you are going through).

    I’m really sorry that didn’t solve the problem. Thank you for letting me know though… I appreciate you taking the time to share your experience!

    Yes, I’ll definitely let you know if I come up with any solutions. If you come across a similar (but more working) e-commerce plugin, please let me know!

    Thank you again!

    Kim

    Plugin Author Mihai

    (@misulicus)

    @mcilrathfamily are you not using WPeC now so we can test ?
    BTW Godaddy is a worse hosting for wordpress. (and for everything else in my opinion)

    Plugin Author Mihai

    (@misulicus)

    Do you guys have any Caching on your hostings ?

    Hello Mihai,

    Yes, GoDaddy has caching…

    Kim

    Hi Mihai,

    Do you think this will be an issue you can help with? Otherwise, I’ll have to find a new plugin.

    Thank you!!

    Kim

    Plugin Author Mihai

    (@misulicus)

    @mcilrathfamily and everyone else that hosts with Godaddy and has this issue.
    For now go into wp-content and rename the file object-cache.php to something else.
    A more detailed technical explanation and solution will be posted within a day.

    Regards

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Checkout (Oops, there is nothing in your cart.)’ is closed to new replies.