Support » Plugin: WooCommerce » Checkout loop (2.1.3)

  • Hi,

    So since the famous update to 2.1.3, I am having a serious issue where no one can checkout on my website.

    Basically, you can go through all the steps and at the end, when you click place order, it goes back to the billing page but the URL will change to checkout/order-pay, which is the Checkout Endpoints in the Woocommerce settings. I use Paypal Advanced Gateway (latest update). If I have a typo on my settings for my Paypal account, I will get an authentication error so the plugin seems to still be working but for some reason I will get trapped in a loop.

    I also use HTTPS and tried to disabled the plugin and unchecked “force https” on woocommerce as well as the HTTPS plugin. Still no luck. Note that I didn’t change any settings for the past 2 months and it always worked. I installed WPML this morning (after the woocommerce upgrade). Not sure if it’s related but I tried disabling it just to make sure and still no luck. Same for Total cache. I pretty much disabled all my plugins and I still have the same issue.

    Anyone is experiencing the same problem?

    Thank you!

Viewing 4 replies - 1 through 4 (of 4 total)
  • I dunno what kind of issue can be, but is always a great idea try updates under a stage environment and take a buckup of the installation before applying the updates: wp-core and WooCommerce updates can be really dangerous!

    Anyway, I have a counter-question for you: your checkout progress is amazing. How does it’s made?

    Hi Spike007,

    Have you found a fix for this? or any other similar threads? I’m having the same issue, only with a fresh install, rather than an update.

    I thought it might be because I have shipping disabled (the site sells digital product only), and yet the shipping address tab on the checkout page is still there, but I’m assuming you have shipping for your chairs, which would rule that out as the cause. for the site, if anyone wants to attempt a checkout and see the problem firsthand.

    Thanks for any help anyone can provide!

    I am not sure if I am the only one experiencing the issue, but with the help of my friend I was able to conclude it is a glitch when you are logged as an admin.

    Long story short, I had the issue using Chrome since it is my main browser. I tried IE and Firefox and both of them worked. However, I was not logged in as an admin. When I logged in, it was still working. So I just logged out (chrome) and logged back in and the issue was resolved.

    Basically, my customers were not affected since I was getting orders while I was trying to figure out the problem.

    Solikewise > I just tried your checkout page and it worked. As I said above, try to log out from your admin account, log back in and try again.

    sardbaba > It is a features of my theme! 😀


    Thanks for trying the checkout. I had actually just fixed it when I saw your “order” come in.

    My issue was my theme had not yet been updated to account for the woocommerce update, and I happened to do my install right in that gap. The theme update rolled out and when I installed it all was well.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Checkout loop (2.1.3)’ is closed to new replies.