Support » Plugin: WooCommerce » Checkout errors after upgrade to 3.0.4

  • After upgrading to the recent version 3.0.4, I now get these repeated errors on the checkout page:

    Warning: array_merge(): Argument #1 is not an array in /home/username/public_html/wp-content/plugins/woocommerce-subscriptions/includes/class-wcs-cart-renewal.php on line 430

    Warning: array_key_exists() expects parameter 2 to be array, null given in /home/username/public_html/wp-content/plugins/woocommerce-subscriptions/includes/class-wcs-cart-renewal.php on line 434

    Warning: array_merge(): Argument #1 is not an array in /home/username/public_html/wp-content/plugins/woocommerce-subscriptions/includes/class-wcs-cart-renewal.php on line 430

    Warning: array_key_exists() expects parameter 2 to be array, null given in /home/username/public_html/wp-content/plugins/woocommerce-subscriptions/includes/class-wcs-cart-renewal.php on line 434

    Warning: array_merge(): Argument #1 is not an array in /home/username/public_html/wp-content/plugins/woocommerce-subscriptions/includes/class-wcs-cart-renewal.php on line 430

    Warning: array_key_exists() expects parameter 2 to be array, null given in /home/username/public_html/wp-content/plugins/woocommerce-subscriptions/includes/class-wcs-cart-renewal.php on line 434

    Warning: array_merge(): Argument #1 is not an array in /home/username/public_html/wp-content/plugins/woocommerce-subscriptions/includes/class-wcs-cart-renewal.php on line 430

    Warning: array_key_exists() expects parameter 2 to be array, null given in /home/username/public_html/wp-content/plugins/woocommerce-subscriptions/includes/class-wcs-cart-renewal.php on line 434

    Warning: array_merge(): Argument #1 is not an array in /home/username/public_html/wp-content/plugins/woocommerce-subscriptions/includes/class-wcs-cart-renewal.php on line 430

    Warning: array_key_exists() expects parameter 2 to be array, null given in /home/username/public_html/wp-content/plugins/woocommerce-subscriptions/includes/class-wcs-cart-renewal.php on line 434

    Warning: array_merge(): Argument #1 is not an array in /home/username/public_html/wp-content/plugins/woocommerce-subscriptions/includes/class-wcs-cart-renewal.php on line 430

    Warning: array_key_exists() expects parameter 2 to be array, null given in /home/username/public_html/wp-content/plugins/woocommerce-subscriptions/includes/class-wcs-cart-renewal.php on line 434

    What is a probable cause please?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Same problem here, any update ? Thanks.

    Thread Starter NetMonkey

    (@headmonkey)

    No update yet, I’m sure someone will reply soon.

    Plugin Author Mike Jolley (a11n)

    (@mikejolley)

    Update the subscriptions plugin; each notice you can see comes from woocommerce-subscriptions.

    You should disable notices and warnings in production https://github.com/woocommerce/woocommerce/wiki/Deprecation-in-core#warnings-in-production-store-owners-read-this

    Hello , i have the same problem even with Woocommerce Membership update and Divi… Could you please be more clear , Woocommerce support didnt give me any solution.

    Thanks ,
    Stéphane


    Warning: array_merge(): Argument #1 is not an array in /home/clubp779/public_html/wp-content/plugins/woocommerce-subscriptions/includes/class-wcs-cart-renewal.php on line 432

    Warning: array_key_exists() expects parameter 2 to be array, null given in /home/clubp779/public_html/wp-content/plugins/woocommerce-subscriptions/includes/class-wcs-cart-renewal.php on line 436

    Warning: array_merge(): Argument #1 is not an array in /home/clubp779/public_html/wp-content/plugins/woocommerce-subscriptions/includes/class-wcs-cart-renewal.php on line 432

    Warning: array_key_exists() expects parameter 2 to be array, null given in /home/clubp779/public_html/wp-content/plugins/woocommerce-subscriptions/includes/class-wcs-cart-renewal.php on line 436

    Warning: array_merge(): Argument #1 is not an array in /home/clubp779/public_html/wp-content/plugins/woocommerce-subscriptions/includes/class-wcs-cart-renewal.php on line 432

    Warning: array_key_exists() expects parameter 2 to be array, null given in /home/clubp779/public_html/wp-content/plugins/woocommerce-subscriptions/includes/class-wcs-cart-renewal.php on line 436

    Warning: array_merge(): Argument #1 is not an array in /home/clubp779/public_html/wp-content/plugins/woocommerce-subscriptions/includes/class-wcs-cart-renewal.php on line 432

    Warning: array_key_exists() expects parameter 2 to be array, null given in /home/clubp779/public_html/wp-content/plugins/woocommerce-subscriptions/includes/class-wcs-cart-renewal.php on line 436″

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Checkout errors after upgrade to 3.0.4’ is closed to new replies.