Support » Plugin: WooCommerce Stripe Payment Gateway » checkout does not proceed

  • Resolved danyusit

    (@danyusit)


    After the last update of the plugin I can no longer process orders on stripe, when I press the button to pay the page returns to the top and nothing happens, stripe cannot take the money from the payment due to errors in the plugin

Viewing 8 replies - 1 through 8 (of 8 total)
  • I also have this exact same issue – an internal server error is shown and the follwing in the server log:

    PHP Recoverable fatal error: Object of class stdClass could not be converted to string in /opt/bitnami/apps/wordpress/htdocs/wp-content/plugins/woocommerce/includes/abstracts/abstract-wc-log-handler.php on line 44′, referer: https://xxxxxxxxx/checkout/

    You will probably find that all is well is you rollback to version 5.50; too many bugs and other issues with the versions of this plugin after that version.

    Plugin Support Felipe (a11n)

    (@felipea8c)

    Hi there!

    This kind of problem is usually caused by a conflict with your theme or with another plugin.
     
    The best way to determine this is to:

    • Temporarily switch your theme to Storefront
    • Disable all plugins except for WooCommerce and Stripe
    • Repeat the action that is causing the problem

    If you’re not seeing the same problem after completing the conflict test, then you know the problem was with the plugins and/or theme you deactivated. To figure out which plugin is causing the problem, reactivate your other plugins one by one, testing after each, until you find the one causing conflict. You can find a more detailed explanation on how to do a conflict test here.

    @threatpointuk and @ttoaster, feel free to open your own topics, so we can take a look at them for you individually, in case you folks still need help. 🙂

    Thanks for the update @felipea8c – actually the issue I described is thrown in – /wp-content/plugins/woocommerce/includes/abstracts/abstract-wc-log-handler.php

    Resolved short term by updating the log handler routine to correctly handle the data format.

    Issue was Introduced following the latest update to woocommerce. I post this just as follow up, no action required.

    thanks.

    Thread Starter danyusit

    (@danyusit)

    “Resolved short term by updating the log handler routine to correctly handle the data format.”

    How can I do it?

    Plugin Support AW a11n

    (@slash1andy)

    Automattic Happiness Engineer

    Hey again @danyusit

    Were you able to do the conflict test requested above?

    Thread Starter danyusit

    (@danyusit)

    I solved, the problem was not from Stripe. Thanks

    Plugin Support Chris Moreira – a11n

    (@chrism245)

    Glad to hear it – thanks for letting us know!

    I’ll mark this thread as resolved now. If you have any further questions, I recommend creating a new thread.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.