Support » Plugin: Hierarchy » Checking/unchecking heirarchical in Pods CPT set up has no effect

  • Resolved perryb


    I’ve just installed Hierarchical on a test site with Pods installed.

    Using the options in Pods admin ( Advanced Options > Post type options ) I was able to change the slug but the check box option for hierarchical ( already set to false ) doesn’t seem to have any effect.

    I have a long list of test CPTs already so hiding them in the nested Content view would make sense. I guess they should have been hidden from the off.

    Checking and un-checking the option in Pods ( and saving ) doesn’t seem to have any effect.

    Will this only work if I hard code my CPTs via functions.php?

Viewing 6 replies - 1 through 6 (of 6 total)
  • What version of Pods are you running?

    Plugin Author Jonathan Christopher


    The checkbox in Pods won’t have much to do with Hierarchy as everything with Hierarchy is based on the slug itself, so if you can give a bit more detail surrounding your setup that’d be great. As Scott mentioned, knowing the Pods version will be helpful, as will knowing what slugs you have set up, what Pages you’re trying to get CPTs showing up under, etc.

    Sorry I forgot to add the version number for Pods – 2.2.

    My set up is pretty rough and ready (a Multisite sandbox really).

    I had an existing page (Sample page – obviously the default page you get when WP is installed).

    I had already created my CPT using Pods too. I really wanted to see if checking options in Pods would work the same way with Hierarchy as declaring the CPTs in functions.php – or a custom plugin for instance.

    After installing Hierarchy I was able to nest my CPT (Questions) beneath Sample Page in the Content view by changing the slug in Pods to sample-page/questions.

    I assumed that following Jonathon’s tutorial ( Introducing Hierarchy ) checking or un-checking the hierarchical option in Pods would be the equivalent of hard coding my CPT, eg:

    'hierarchical' => false,


    'hierarchical' => true,

    As it stands the list in Content appears populated with all my CPTs regardless whether or not this option is checked.

    Sorry if I’m restating what I have already said above. Is there any more specific information you need that would help?

    Ah – I realise what I’ve done now.

    In the tutorial: ” If hierarchical is true, a populated Team section would look something like this:” then there is a screen shot.

    I took it that if set to true that this would just populate the list – not simply change the ordering.

    To display or not display entries in the Content list simply check or un-check “Show Entries” next to the CPT in Hierarchical settings.

    Just to confirm checking or un-checking Hierarchical in Pods settings does behave as it should do.

    Sorry for taking up your time with this Jonathon and Scott

    Plugin Author Jonathan Christopher


    Ah ha, I think I’ve followed what you went through and that makes senseā€”at this point are you comfortable with the way both plugins are working cooperatively?

    That’s generous of you :).

    No it’s a great plugin ( I can now say that without qualification! ).

    As far as I can tell Hierarchy and Pods work fine together. Now I’ve got over my conceptual hump I can have look at what else I can do.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Checking/unchecking heirarchical in Pods CPT set up has no effect’ is closed to new replies.