Support » Plugins and Hacks » Picasa and Google Plus Express » [Resolved] checking user: nok: Response code is 404 – transport: curl

[Resolved] checking user: nok: Response code is 404 – transport: curl

  • Hello,

    I switched back to version 1.5.4. while the option to show html instead of the [pe…] link was not available.

    At first all was ok, then I updated to 2.0.4 (I think) because the option was available. This is where the problem started.

    In the settings it shows “You have successfully authorized access to private albums.” but it also shows “checking user: nok: Response code is 404 – transport: curl“.

    I tried to revoke and grant access now a few time. I deinstalled the plugin and installed it again, … no change to the state. It seems the seetings are kept while not installed.
    Is there an option to delete the settings as well?

    Any ideas out there how to resolve this?

    Thanks in advance


Viewing 9 replies - 1 through 9 (of 9 total)
  • Additional info:

    in the meantime I found the options in wp_options. I revoked access permissions, deinstalled the plugin, deletet the pe2_* settings in the table, installed the plugin, did the settings, saved and then granted access.

    No change to state… it is not working 🙁

    I host another site with same wordpress version and same plugin installed on the same server … it’s working.

    So, what’s the difference?

    Thanks in advance

    Plugin Author gjanes


    I’ll have to investigate this a bit further to determine what the URL might be that’s returning the 404. I’ll get back to you.

    Plugin Author gjanes


    Looking at the code, the only way the URL could be a 404 is if the username wasn’t probably populated in the token request URL.

    The token itself is stored in different places based on whether you have user or blog level access configured for pe2. If you have user-level access configured, the pe2_username and pe2_token will be stored in the _user_meta table instead of the _options table.

    I’m wondering if somehow those settings got goofed up, perhaps in the upgrade or the switch in versions back and forth. If you are indeed using user level configuration for pe2, check the _user_meta table for pe2_* records that would also need to be removed.

    Hi there,

    I double and triple checked table wp_usermeta but there is absolutely no entry related to pe2_* or anything alike. 🙁

    Any other ideas?

    Thanks in advance.

    I noticed something:

    I cleared the wp_option settings once again. “checking user: ok – transport: curl” ist shown while the name is “undefined” (no access granted.

    As soon as I change it to anything else it changes to “checking user: nok: Response code is 404 – transport: curl”.

    This state is also set after I grant access then.


    Plugin Author gjanes


    I just updated a copy of the plugin under the development version here:


    Please download and install that version of the plugin. This will provide a slightly different message, including the URL its attempting to verify. This should help us determine what is going on.

    Hi there,

    I installed the developer version and this is the URL behind the now shown link:


    8347p37 is the “picasa username” in the settings…

    Ok, this is strange…. I just named it like it is in the google login/email address and now it works.

    1. It was never named like this in the past and it worked
    2. I’m a 100% sure, that I already tried this combination since the error occurred. Why does it work now??

    In my understanding this is just a short name or an alias and does not need to be identical with the google login, … at least in the past?

    Best regards
    Christian Reitz

    Plugin Author gjanes


    My guess is that the old shorthand username simply doesn’t work anymore. I had to make several changes to the authentication logic in version 2.0 because of changes on Google’s side, and I’m guessing this is another change they made on their side. Navigating to the URL you provided yields:

    Unable to find user with email 8347p37@gmail.com

    So I’m sure what has happened is the continued migration from picasaweb to Google+ is causing certain older features of picasaweb (like this shorthand username option) to be removed.

    I will add this issue to the FAQ, as it certainly could be possible for others to run into the same problem. We’ll probably continue to see features on Google’s side to continue to change as the migration progresses.

    Probably this is the reason… for now I can work with it. If it does not limit the use of the plugin everything is fine 😉

    I thank you very much for your time! Good work! *thumbs up*


Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Resolved] checking user: nok: Response code is 404 – transport: curl’ is closed to new replies.
Skip to toolbar