Support » Plugin: Autoptimize » Checking Optimize CSS causing navigation menu under footer

  • Resolved tonywaller

    (@tonywaller)


    I installed autoptimize and checked the Optimize CSS Code box. Now a navigation menu at the bottom of the page appears. When I uncheck Optimize CSS Code box, the menu goes away.

    Thanks,
    Tony

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Optimizing Matters

    (@optimizingmatters)

    can you try excluding the theme or navigation plugin’s CSS from CSS optimization Tony?

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    any news tonywaller ?

    Thread Starter tonywaller

    (@tonywaller)

    I contacted GeneratePress support and added the CSS file to the exclusion list. This corrected the issue reported above, but I also have an issue with icons on a contact form when I activated Autoptimize – I’m using Happy Forms. I don’t have time to troubleshoot this issue any more at this time, so I have disabled Optimizing CSS for now.

    • This reply was modified 1 month ago by tonywaller.
    Plugin Author Optimizing Matters

    (@optimizingmatters)

    So it works when “inline & defer CSS” is off but “optimize CSS” is on Tony (can’t check as the URL you have in the original topic is behind basic authentication)?

    Thread Starter tonywaller

    (@tonywaller)

    I have temporarily removed the login requirement for the site. I checked ‘Optimize CSS’ and added the CSS file to the exclusion list again. This resolved the navigation bar at the bottom of the window. However, the formatting for the contact forms is now off. You can check the Join Our Team page to see what I am referring to.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    OK, can you try adding /plugins/happyforms-upgrade/ to the comma-separated CSS optimization exclusion field?

    Thread Starter tonywaller

    (@tonywaller)

    Ok. That resolved the contact form issue. I found another while continuing to test. For mobile, when I touch menu, the menu appears but without the green background color, so the menu blends in with the webpage, making it difficult to see the menu.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    Can you try disabling “also aggregate inline CSS” for that Tony?

    Thread Starter tonywaller

    (@tonywaller)

    That change resolved the contact forms issue. I’ll continue to test as configured now and hopefully will not find any more issues. Thanks for your help!

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    sure, feel free to keep me posted here 🙂

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.