WordPress.org

Support

Support » Plugins and Hacks » Postie » [Resolved] Checking for mail manually – no emails found

[Resolved] Checking for mail manually – no emails found

  • postie doesn’t find new mail anymore.

    after succesfully testing the config, running postie manually does not seem to work.
    i have configured postie with pop3. when hitting the run postie button, all i get is the message: Checking for mail manually. i have a bunch of new emails sitting in the inbox.

    also strange is, when entering the wrong password an testing the config, i do get an okay.

    how can i get postie to print out more debug information?

    thanks

    http://wordpress.org/extend/plugins/postie/

Viewing 15 replies - 16 through 30 (of 30 total)
  • Plugin Author Wayne Allen

    @wayneallen-1

    Are there no entries after “Postie: Checking for mail manually”

    There should be something like “Postie: Done”

    If not then something is crashing along the way. Do you have web server logs you can look at?

    okay, interesting hint. here’s the log entry:
    [Tue Feb 05 21:18:07 2013] [error] [client 80.74.128.17] mod_security: Access denied with code 406. Pattern match “(TwengaBot|Voila|MJ12bot|Baiduspider|WordPress|psbot|Yeti|WebofantBot|WebAlta|Bloglines)” at HEADER(“USER-AGENT”) [severity “EMERGENCY”] [hostname “sime.li”] [uri “/wp-cron.php?doing_wp_cron=1360095487.1282510757446289062500”]
    [Tue Feb 05 21:18:07 2013] [error] [client 80.74.128.17] File does not exist: /home/httpd/vhosts/sime.li/error_docs/not_acceptable.html

    when executing the wp-cron.php by directly pasting it into the address bar, postie works fine….

    does not make sense to me. anyone knows mod_security?

    Plugin Author Wayne Allen

    @wayneallen-1

    I’m not sure mod_security is the issue as it deals with incoming requests, not outbound IMAP sessions or PHP modules. Look in your error log.

    hmm, i don’t understand. that is the error log. anywhere else i can look?

    Plugin Author Wayne Allen

    @wayneallen-1

    Sorry I was thinking that was the access log.

    You could look at your php.ini file and turn on some addition error display
    http://www.php.net/manual/en/errorfunc.configuration.php

    I’m having the same issue and am using an Exchange address. Does that matter?

    Plugin Author Wayne Allen

    @wayneallen-1

    Yes, MS Exchange doesn’t play nicely with IMAP.

    What do you get when you press the Test button?

    Can you use POP or another mail server entirely?

    I’m afriad IMAP is all that’s available to me.

    Here’s what I get when I click the test button:

    International support
    iconv: installed
    imap: installed
    mbstring: installed

    Clock TestsThis shows what time it would be if you posted right now
    GMT: 2013-06-27 15:17:46
    Current: 2013-06-27 15:17:46

    Connect to Mail Host
    Successful IMAP-SSL connection on port 993
    # of waiting messages: 0

    Plugin Author Wayne Allen

    @wayneallen-1

    What version of Postie are you using? I would expect to see more details and there have been some recent Exchange improvements.

    1.5.0. With this version as long as I access the site, the posting happens. But when I tried to update to 1.5.12, I had trouble posting at all.

    Sorry, I realized I should clarify something.

    The issue I’m currently running into is that the automatic checking for emails isn’t happening. I have the “Check for mail every” setting in the “Mailserver” tab set to every 5 minutes. But that doesn’t happen. Emails are posted only when someone accesses the site.

    Plugin Author Wayne Allen

    @wayneallen-1

    The WordPress cron only runs when pages are being accessed. If you want to ensure posts are being created see:

    Forcing an Email Check

    I didn’t have access to the server on which Word Press was installed. So I found out who could help me and they were able to set up a cron job. I’m all set. Thanks for the help!

    Plugin Author Wayne Allen

    @wayneallen-1

    Glad its working!

    Wayne,
    I have the same problem with IMAP on MS Exchange as described above.

    0 messages reported when I know the mailbox is not empty.

    I have enabled the debugs and spotted the following line from php debug when launching postie with debug output:


    Connecting to mail.mydomain.tld:993 (imap-ssl)
    IMAP: connection string - {mail.mydomain.tld:993/service=imap/ssl/notls/novalidate-cert}
    IMAP: disabling GSSAPI
    IMAP: connected
    stdClass Object
    (
    [flags] => 0
    )

    Notice: Undefined property: stdClass::$messages in /var/www/wp/wp-content/plugins/postie/postieIMAP.php on line 109
    IMAP: expunge
    IMAP: closing connection
    There are 0 messages to process

    php-imap is version 5.3.3-23 as from my package manager.

Viewing 15 replies - 16 through 30 (of 30 total)
  • The topic ‘[Resolved] Checking for mail manually – no emails found’ is closed to new replies.
Skip to toolbar