Support » Plugin: WP Mailster » checking connection, certificate mismatch

  • Resolved eLeXeM

    (@elexem)


    Hello there;
    i have a problem very similar to the situation described in https://wordpress.org/support/topic/imap-connection-problem/ ; however, wasn’t able to bypass it by just setting the inbox to tls on port 143. My Mailserver help tells me to set

    • Host/Server : mail.liberal.is
    • Port : 993
    • Connect via : SSL
    • Use secure authentication : yes

    but when I do, I get a fail testing that connection stating “Certificate failure for mail.liberal.is: Server name does not match certificate: /CN=*.orangewebsite.com”. I’ve already been in touch with my hoster, how flat out deflected; stating

    It is not a server wide issue please contact your plugin provider and if they suggest any changes from the server side we will do it for you.

    :/

    So, uh; anything you can do to help? Cheers – LX

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • found a solution with the hoster in the meantime. had to use their own internal server naming, not the external domain. Cheers + sorry
    LX

    • This reply was modified 2 months, 2 weeks ago by  eLeXeM.
    Plugin Author brandtoss

    (@brandtoss)

    Hi LX,

    there is also a general solution.

    From our FAQ (https://wpmailster.com/faq/):

    Why do I get a “Certificate failure” error message upon checking the inbox connection?
    You might get an error message like this when checking the connection settings: “Certificate failure for [server] Server name does not match certificate” or “Certificate failure for [server] unable to get local issuer certificate”.

    If you use your own mailing server (with a self-signed certificate) you need to deactivate the automated certificate check to get a connection to your inbox.
    Do this by adding the following line in the special parameter box: /novalidate-cert

    Glad you got it working though!

    Thanks,
    brandtOSS

    • This reply was modified 2 months, 2 weeks ago by  brandtoss.
    • This reply was modified 2 months, 2 weeks ago by  brandtoss.
    • This reply was modified 2 months, 2 weeks ago by  brandtoss.

    good to know there’d be another way of tackling this 🙂
    + cheers for responding.
    Best – LX

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.