Support » Plugin: SEO Ultimate » Checkbox not working (Nofollow: Tell search engines not to spider…)

  • Resolved Ed Orsini

    (@edorsini)


    For a post or page, under the SEO settings, after you select the checkbox containing “Nofollow: Tell search engines not to spider links on this webpage.” and save the post or page, the checkbox is unchecked.

    In other words, the checkbox does not save the value. It resets to to unchecked and saves it.

    Is anyone having this same problem?

    Thanks,

    — Ed

    http://wordpress.org/extend/plugins/seo-ultimate/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Quick update:

    I found the culprit and have fixed the issue. In case anyone is interested, the issue is in the function: save_postmeta_box() in seo-ultimate/plugin/class.seo-ultimate.php

    In short, the meta_robots_noindex key would be fine. However, the meta_robots_nofollow key would get lost. The code was expecting the key to be “meta_robots_noindex|meta_robots_nofollow” to work properly, but the code was generating only “meta_robots_noindex”. If you add the following if statement above the explode line, it will work:

    if ($fields == 'meta_robots_noindex') {
      $fields .= '|meta_robots_nofollow';
    }

    Again, this is only a quick fix and hopefully this will be patched on the next version.

    Plugin Contributor John

    (@johnlamansky)

    Thank you for the bug report, Ed. This will be fixed in the next version.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Checkbox not working (Nofollow: Tell search engines not to spider…)’ is closed to new replies.