Support » Plugin: Google Forms » Checkbox not registering all answer

  • I used checkbox type of question, however google form records only last answer, not all of them (comma separated). Standalone form records answers correctly.

    I have seen one of the questions here about this case, but it is supposed to be resolved. Well – it isn’t… Can anyone replicate this?

    http://wordpress.org/plugins/wpgform/

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Mike Walsh

    (@mpwalsh8)

    It is hard to answer this question without actually seeing your form and the data submitted. First question – is your version of WordPress Google From up to date? The checkbox problem was fixed a while ago but I always have to ask.

    Do you have any Javascript errors on your page? If so, this is likely the cause because there is a small jQuery script which runs which “fixes” the checkboxes so they are compatible between PHP (which WordPress uses) and Python (which Google uses). If this jQuery script doesn’t run, your results, particularly for checkboxes, will be suspect.

    Plugin Author Mike Walsh

    (@mpwalsh8)

    I took a look at this problem last night and it was introduced with the changes I made in v0.63 to better support PHP 5.4 and later. Unfortunately that change breaks support for checkboxes so I have reverted back to constructing the body parameter for wp_remote_post() manually.

    I have an early build of v0.64 available if anyone wants to do any testing, I will likely push it out in the next day or so.

    Plugin Author Mike Walsh

    (@mpwalsh8)

    I have continued working on this problem and found the source of it to be a change to the WordPress HTTP API that causes this problem to happen. The change to the API means that the cURL transport is the only which works in versions of WordPress 3.7 and later.

    I have a new build on my web site to try which detects when cURL isn’t present and issues a warning. This build also cleans up some of the issues with passing checkbox parameters.

    Hello Mike!
    I also had problem with checkbox type of question. I have just downloaded GOOGLE FORMS V0.64-BETA-3. and test it – so far so good.
    Have you found any issues to fix? I am just asking as I would like to use the plugin in a campaign and I would like to make sure if i can rely on it.
    Thanks!!!!

    Plugin Author Mike Walsh

    (@mpwalsh8)

    All of the testing I and others have done with the latest beta show it is working well. The only thing I have yet to verify is testing UTF-8 characters which some non-English languages utilize.

    Great! Thanks very much!

    Hello!
    I have just found a bug.
    When i use checkbox type of question and I use “other: ” option, too, at the end, the answer isnt recorded.
    Thanks for checking.

    Sorry.. and another one
    If the plugin is switched on I cannot upload images in the media library..
    It seems quite obvious it is because of this plugin, because when I switch it off it works the media upload again..

    me again..:( lots of conflicts with woocommerce..:(

    Plugin Author Mike Walsh

    (@mpwalsh8)

    Some more details on these problems would be really helpful. I use WooCommerce extensively and have not run into any problems nor have I seen any conflicts with the media uploaded. If you look at my site I have images on many of the posts all of which are uploaded with the standard media uploader.

    I am not saying that this plugin is without flaws but what you’re reporting would certainly have come up before. What have you tried to isolate the problem?

    Hello!
    My WP version is WP 3.8.1 woocomomerce 2.0.20.
    What happens after installed the GOOGLE FORMS V0.64-BETA-3.
    I get error messages on the admin site saying “Action failed. Please refresh the page and retry” – eg at WooCommerce/settings or WooCommerce/customizer, or the media library)
    When I switched the plugin off they worked again. I also tried to switch my other plugins off one-by-one to see if there is a particular one the may cause problem, but they were OK.
    Your GoogleForm plugin is great! I would love to use it.
    I hope things can get fixed..

    Plugin Author Mike Walsh

    (@mpwalsh8)

    I would do two things:

    1. Update Google Forms to latest beta-6 version.
    2. Update WooCommerce – your version is out of date. WooCommerce is now at 2.1.2.

    If you still have the problem after doing this let me know. I am running WooCommerce on several sites and am not seeing this issue.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Checkbox not registering all answer’ is closed to new replies.