WordPress.org

Forums

[resolved] "Cheating, uh?" error message when activating Polished 4.0 theme (18 posts)

  1. Autonomous
    Member
    Posted 1 year ago #

    Hello all,

    I'm working on a new Cyber Security blog as a class project (Cyber Security & Web Development). I have well over a year to complete this, so I decided to use WordPress since its a platform I'm not yet familiar with, & it'd be a learning experience. In other words, expect to see me here a lot, haha.

    I'm using a them from Elegant Themes titled Polished, version 4.0

    At first, after activating the theme I'd get a completely blank page, so I nulled the theme directory & switched back to the default theme. Edited some permissions on the directories & now I'm receiving the "Cheating, uh?" error message. I've done some research & haven't come up with any solutions.

    I am working on the site locally on an in-house server, so I'm not using any FTP Clients, & I'm using WAMP for hosting.

    Any ideas on what could be going on here?

  2. esmi
    Forum Moderator
    Posted 1 year ago #

    Edited some permissions on the directories

    Edited what permissions where? You probably won't appreciate the irony of this but you've just fallen foul of WordPress' inbuilt security.

  3. Autonomous
    Member
    Posted 1 year ago #

    Haha I appreciate the irony, as I said, this is a completely local project, so security isn't a huge concern right now. Once I know a little more about the platform, then I'll work on the security, but most likely this site will remain on an external harddrive for presentation purposes.

    It may never actually go live, if that helps ease security concerns.

  4. Autonomous
    Member
    Posted 1 year ago #

    I edited the permissions for the "Polished" directory & its subfolders. By default, it was set to read-only. I read a lot that during the activation process that could propose a problem.

  5. esmi
    Forum Moderator
    Posted 1 year ago #

    A read-only file or folder on a WAMP server shouldn't cause any problems for a theme. I can only guess that there is an issue in the theme. I'm sorry but as you are using a commercial theme, you need to seek further support from the theme's developer/vendor. We do not have access to, nor do we support, commercial products here.
    Try http://www.elegantthemes.com/forum/

  6. Autonomous
    Member
    Posted 1 year ago #

    I've seeked support there as well, thank you, though.

    The problem happens with any third-party theme, & I first thought it would be a compatibility issue, but many users are using the theme with 3.9.1 as well, so I'm not sure what the issue may be at this point.

  7. esmi
    Forum Moderator
    Posted 1 year ago #

    What about the 2014, 2013 or 2012 themes? Are they working OK?

  8. Autonomous
    Member
    Posted 1 year ago #

    I can say the 2014 is working fine, I don't have the others installed.

  9. esmi
    Forum Moderator
    Posted 1 year ago #

    Try https://wordpress.org/themes/twentythirteen or https://wordpress.org/themes/twentytwelve

    My guess is that they will work OK too and that the problems you are having are specific to your commercial theme.

  10. Autonomous
    Member
    Posted 1 year ago #

    Both of those gave me a permissions error.

    "You do not have sufficient permissions to access this page" upon trying to activate..

  11. esmi
    Forum Moderator
    Posted 1 year ago #

    Looks like you have a problem in your local server. Moving this to the Localhosts forum.

    How are you adding these themes to your install?

  12. Autonomous
    Member
    Posted 1 year ago #

    Just by installing the zip files from the 'Upload' option in WP-Admin.

    I dread this, but I'm going to try a fresh install of WordPress & the theme to determine if its my server or just a corrupt installation. I haven't done too much work yet so not a big deal.

  13. esmi
    Forum Moderator
    Posted 1 year ago #

    Can you try unzipping the downloaded archives and just dropping the theme folder into wp-content/themes to see if that helps.

  14. Autonomous
    Member
    Posted 1 year ago #

    Fresh WordPress 3.9.1 install.

    Unzipped Polished theme & manually added the folder to /wp-content/themes

    Now I'm just getting the blank page issue again.

  15. Autonomous
    Member
    Posted 1 year ago #

    Got it working! Thanks for all your help.

    For any readers with a similar issue with this theme, there is a configuration file in the theme & in line 35, change the version number.

    Mine was set to 3.4.1, so I changed it to my version number & reactivated with success.

  16. esmi
    Forum Moderator
    Posted 1 year ago #

    Whatever you do, do not do that on a live site!

  17. Autonomous
    Member
    Posted 1 year ago #

    What would be the security risk in that? It looks to be just for referencing the WordPress version?

  18. esmi
    Forum Moderator
    Posted 1 year ago #

    If that theme was intended for WordPress 3.4.1, then it shouldn't be used on WordPress 3.9.1. It may not even function properly on a remote PHP 5.4 (for example) server! It's... well, pretty old.

Topic Closed

This topic has been closed to new replies.

About this Topic