Support » Plugin: Image Watermark » ‘Cheatin uh’ error

  • Resolved markoposavec

    (@markoposavec)


    Starting today, not immediately after updating to the latest version, a “cheatin uh?” error started to appear in my Media Library whenever I try to add a watermark to an image.

    No changes whatsoever were made when this started appearing (at least none that I am aware of).

    This happens in bulk watermarking mode. Backups are disabled.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Did you tried a hard refresh? Or if that didn’t work, logout and login again?
    It’s most likely a session/timeout error.

    Thread Starter markoposavec

    (@markoposavec)

    Tried it, didn’t work.

    I have since updated WordPress and the theme to the latest version, but that didn’t help either.

    What’s most puzzling is that the error just started appearing out of nowhere, no changes whatsoever were made at that time.

    Thread Starter markoposavec

    (@markoposavec)

    It is perhaps worth noting that the watermark application mechanism appears to have changed since the update: instead of reloading the Media Library page, it now displays a spinning circle-thing over the thumbnail just before it drops the “Cheatin uh?” error.

    Switching to Twenty Sixteen is no good, so it’s probably not theme-related. I have also tried disabling other plugins and that didn’t help either.

    All users of the site have the same problem.

    Plugin Author dFactory

    (@dfactory)

    Hi,
    If you submit a thread on our support forum you’ll be able to post private reply with temporary login credentials. Then we’d be able to check that on your site as we can’t replicate the issue in our installs.

    Regards,
    Bartosz / dfactory team

    I am getting the same ‘Cheating Uh?’ error, when I try to apply watermark.

    @bartosz I think I’ve found the problem, check PR on GitHub: https://github.com/dfactoryplugins/image-watermark/pull/6

    @wordpressuser832 & @markoposavec
    If you are able, please test this change!

    Thread Starter markoposavec

    (@markoposavec)

    It works! I have changed the two files and now it’s flawless.

    Thank you very much 🙂

    Perfect! Thanks for testing 🙂

    If you’ve taken every change you’ll now also have some dev fixes (hopefully for the next minor release if dFactory accepts my PR):

    • Prevent watermarking the watermark image
    • Trigger bottom apply button for bulk actions
    • UX: When using bulk, let the browser scroll along with the progres

    Thank you so much, this has fixed the issue.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘‘Cheatin uh’ error’ is closed to new replies.