Support » Plugin: Adminimize » “Cheatin’ huh?” Error page

  • Resolved adammontague

    (@adammontague)



    I’m getting the “Cheatin’ Huh?” error message page when trying to view Woocommerce Products post type as a Shop Manager user role.

    Deactivating Adminimize fixes this. I’m running the latest 1.11.1 of Adminimize.

Viewing 15 replies - 1 through 15 (of 18 total)
  • Plugin Author Frank Bueltge

    (@bueltge)

    If you have hide this page in the settings of Adminimize then is it now, since the 1.11.0 version, also include a prevent for this page. But you can deactivated this new function in the plugin settings of Adminimize, last option.

    I’ve fixed it. I still think this is possibly a bug?

    I deactivated “Tags” under the Products post type for Shop Managers user role – for some reason this was effecting the entire post type. I enabled Tags and now my Shop Managers can view the post type.

    Plugin Author Frank Bueltge

    (@bueltge)

    In short, you have only active the page “tags” for roles to hid this menu item. But the the post type WooCommerce is also not possible to access?

    I was only hiding Tags but it was preventing Shop Manager users from seeing the entire Products post type.

    Plugin Author Frank Bueltge

    (@bueltge)

    Thanks, I will check this in the prevent page function.

    Hi Frank and Adam,

    Just following, having the same behaviour here.

    Plugin Author Frank Bueltge

    (@bueltge)

    @frank4 also on WooCommerce or other custom post type?

    Hi Frank,

    This happens on Events Calendar Pro Custom Post Type (Modern Tribe).

    Have the same problem here,
    when trying to hide categorys or tags (woocomerce)
    from shop manager they get the cheatin error,
    before the update everything worked well,
    how do I make it like before (just hide dont prevent)?
    Thank you,
    Asaf

    • This reply was modified 1 year, 10 months ago by  asafmazuz.

    Ok I found that plugin option that you (the plugin author) talk about in the first command,
    Thank you its working now

    Same problem here, I was also hiding tags for woocommerce products and I couldn’t access the product page.

    I have a similar problem but not woocommerce instead Grassblade xAPI content. Going to try the tags suggestion but seems a bug.

    The tags fix did not work for me. I have temporarily fixed it using the:

    Allow Page Access [ ] Activate this option to allow access to pages of the back end, even if it’s hidden to a user role.

    Option which is not ideal. It seems to be custom content types. In my case a gb_xapi_content when being listed etc.

    Plugin Author Frank Bueltge

    (@bueltge)

    A new version is ready for release, but a test would really fine. If you can test it, please do it and give me feedback.
    The download is here: https://github.com/bueltge/Adminimize/releases/tag/1.11.2-RC1
    Overwrite the current plugin installation and test.

    Thanks.

    Hi Frank,

    Working on my side (Modern Tribe CPT – Events Calendar Pro) but must check the Allow Page Access setting. Possible to fix without checking it?

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘“Cheatin’ huh?” Error page’ is closed to new replies.