Support » Plugin: WP Maintenance Mode » Chatbot not wokring

  • Resolved vidushishah10

    (@vidushishah10)


    Hello,

    Chatbot is not working in my wbesite. Blank chat option is showing. I have deleted all cache folder also I tried to replace the line in wp-maintenance-mode.php
    $upload_dir = wp_upload_dir();

    // force HTTPS
    $upload_dir[‘baseurl’] = set_url_scheme($upload_dir[‘baseurl’], ‘https’);

    Still not working!

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author George J

    (@georgejipa)

    Hello @vidushishah10,

    Please post your website’s URL.


    George

    Plugin Author George J

    (@georgejipa)

    @vidushishah10 I think the uploads directory (/wp-content/uploads/) is not writeable because /wp-content/uploads/data.js (the bot’s configuration file) is missing.

    After you make that directory writable, you’ll have to save the bot’s settings again (to generate that configuration file).

    Changing File Permissions

    • This reply was modified 3 months, 1 week ago by George J.

    I gave access to wp-content (777) folder! Still not working

    Plugin Author George J

    (@georgejipa)

    @vidushishah10 You should enable debugging (WP_DEBUG), and check wp-content/debug.log after you save the bot’s settings. Maybe there is an error…

    https://codex.wordpress.org/WP_DEBUG

    Also, try to change the permissions just for wp-content/uploads.

    • This reply was modified 3 months, 1 week ago by George J.

    Warning: include(/home/entelech/public_html/wp-content/advanced-cache.php): failed to open stream: No such file or directory in /home/entelech/public_html/wp-settings.php on line 95

    Warning: include(): Failed opening ‘/home/entelech/public_html/wp-content/advanced-cache.php’ for inclusion (include_path=’.:/opt/cpanel/ea-php56/root/usr/share/pear’) in /home/entelech/public_html/wp-settings.php on line 95

    Warning: Cannot modify header information – headers already sent by (output started at /home/entelech/public_html/wp-settings.php:95) in /home/entelech/public_html/wp-content/plugins/wp-maintenance-mode/includes/classes/wp-maintenance-mode.php on line 616

    Warning: Cannot modify header information – headers already sent by (output started at /home/entelech/public_html/wp-settings.php:95) in /home/entelech/public_html/wp-content/plugins/wp-maintenance-mode/includes/classes/wp-maintenance-mode.php on line 617

    Warning: Cannot modify header information – headers already sent by (output started at /home/entelech/public_html/wp-settings.php:95) in /home/entelech/public_html/wp-content/plugins/wp-maintenance-mode/includes/classes/wp-maintenance-mode.php on line 618

    There are errors from plugin php file

    I have solved all errors….wp debug is true and you can check there is no error…Still not showing chat bot

    Plugin Author George J

    (@georgejipa)

    Those warnings appear because wp-content/advanced-cache.php is missing, but that file has nothing to do with the plugin.

    As far as I see, wp-content/uploads/data.js is generated, and the bot works now. 🙂

    https://www.dropbox.com/s/pehimm4gubc85qq/bot.png

    • This reply was modified 3 months, 1 week ago by George J.
    • This reply was modified 3 months, 1 week ago by George J.

    Thanks

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.