Support » Plugin: Inline Google Spreadsheet Viewer » Chart Legend Labels Not Showing

  • Not sure what changed, but Legend labels are not longer showing on any of our charts, both column and line charts.
    I’ve read through the documentation, along with the docs at Google Charts, but I’m unable to understand what is wrong.
    Here is one of our chart shortcodes:
    [gdoc key=”https://docs.google.com/spreadsheets/d/1xW8ZGLOpewd34RBUMIjR2kNYUYmIdcsXIwPSLzzM1IA/edit#gid=1866360012″ chart=”Column” chart_legend=”true” chart_height=”500″ query=”select A,B,C,D,E,F,G,H,I,J” title=”Key West Airport Date – Passenger Arrivals” use_cache=”no” ]

    Anyone have an idea on how to get the labels to appear on the legend? Right now the legend has color blocks, but no label.

    Thanks!

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Thread Starter southernmost

    (@southernmost)

    Anyone help here? We still cannot figure out why the legend labels no longer appear on our charts.

    We have tried disabling all plugins, and changing themes. None of these brought the labels back.

    We have also tested embedding a Google Sheet Chart (without the plugin, just using the embed code that Google Sheets chart provides, and that successfully displayed label legends.

    Any help is greatly appreciated.

    contactink

    (@contactink)

    Hi @southernmost,
    I got this to work by adding: csv_headers=”1″ to the code.
    It will add the Years next to the color blocks.
    Copy the code block below over yours.

    
    [gdoc key="https://docs.google.com/spreadsheets/d/1xW8ZGLOpewd34RBUMIjR2kNYUYmIdcsXIwPSLzzM1IA/edit#gid=1866360012&#8243" 
    csv_headers="1" 
    chart="Column" 
    chart_legend="true" 
    chart_height="500" 
    query="select A,B,C,D,E,F,G,H,I,J"
    title="Key West Airport Date – Passenger Arrivals"
    use_cache="no"
    ]
    
    

    If it doesn’t work, perhaps take a look at my thread here

    Thread Starter southernmost

    (@southernmost)

    Thank you Vincent!! Adding csv_headers=”1″ worked!
    You are a gem for taking the time to solve this for me. This solution, since it appears to be something new from Google Charts 7 months ago, should be added to the instructions and documentation for the plugin.

    Thanks again Vincent!

    danielejanuario

    (@danielejanuario)

    Many thanks @contactink
    I´ve been looking a solution for a long time 🙂

    You’re welcome @danielejanuario
    Glad it helped!
    Vincent

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Chart Legend Labels Not Showing’ is closed to new replies.